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Introduction
WXtoImg is fully automated weather satellite recording, decoding, editing, and viewing software. WXtoImg
supports map overlays, advanced colour enhancements, 3-D images, animations, multi-pass images, projec-
tion transformation (e.g. Mercator), text overlays, automated web page creation, temperature display, and
control for many weather satellite receivers, communications receivers, and scanners.

WXtoImg supports both APT transmissions from polar orbiting satellites and WEFAX transmissions from
geostationary satellites. WXtoImg has a built in set of image processing facilities, but can output raw
images for further processing. Output is in JPEG, PNG, BMP, PBM (PGM/PPM/PNM), or AVI format.

WXtoImg attempts to produce reasonable images from receivers which have too narrow an IF bandwidth
(e.g. scanners) although there are limitations on what can be done.

WXtoImg uses the telemetry data on NOAA APT images to very accurately calibrate the image, correct for
non-linearities in signal strength, and make adjustments for gain changes across the pass. The telemetry
data is also used to calibrate the instruments to provide for very accurate temperature readings.

On GOES satellites, the grayscale is used to correct for non-linearities in signal strength and normalise the
image. Accurate temperature calibration on IR images is also performed.

On other satellites, the grayscale and black and white bars are used to adjust the gain.

WXtoImg uses a PLL technique to correct for doppler shift and ensure straight images on NOAA satellites
ev en in the presence of very high noise levels or poor signal quality. A burst cycle PLL is used on Meteor
and Resurs satellites to correct for doppler shift and to help ensure the images are straight.

Status and Information Lines
Across the top of the WXtoImg display are several tabs (Image, Audio Files, Raw Images, and Saved
Images). Upgraded versions will also have Composites, and Animations. The first tab (Image), is
WXtoImg’s main display. This is where decoded images will be shown and where the image will be dis-
played while recording. All the other tabs show thumbnails of audio files, raw images, saved images, or
animations that were created by WXtoImg. Note that images or audio files manually copied into WXtoImg
directories will not be shown. Clicking on a thumbnail will open the associated file. This provides an easy
means of reviewing a day’s (or week’s, or month’s) satellite passes.

At the top of the WXtoImg Image screen, above the image, is the information line. When an image is dis-
played, the information line will display the satellite name or type and the date and time (in UTC) at which
the image begins. For APT satellites, the satellite direction of travel, maximum elevation (in degrees above
the horizon) and azimuth (E or W) at maximum elevation will be shown when available. For NOAA APT
satellites, the two channels will also be given. For WEFAX images, the digital header information will also
be given in parenthesis (when available).

At the bottom of the WXtoImg screen, below the image, are two status lines. The bottom line indicates the
processing that is being performed, shows warnings and sometimes hints. The top status line is divided into
a number of sections, the leftmost section shows the current UTC time. To the right is the sub-information
line, this usually shows the satellite elevation and azimuth along with image coordinates under the cursor,
but while recording will show information about the recorded satellite’s location, and at certain times other
information may be shown. Next, to the right, is that latitude and longitude display -- when the cursor is
over an image that has an associated overlay map this will show the latitude and longitude (WGS84) under
the cursor. Next is the distance display, showing the distance from the ground station location to the loca-
tion under the cursor. Just to right of this is the temperature indication. When displaying NOAA or GOES
images, the temperature under the cursor is displayed in this section. The units of temperature (C, F, or K)
may be changed under GUI Options in the Options menu. To the right of the temperature indicator is the
seconds into recording display. This gives the number of seconds into the recording under the cursor. It is
especially useful when using Partial Decode to determine which part of a signal to decode. The rightmost
section gives the volume used when decoding the image. During recording it shows the volume. Normally
the receiver volume should be adjusted so the volume shows between 50.0 and 75.0 (see Required Calibra-
tion under the Help menu for more details).
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File Menu
This menu is used to select the file to decode and the filename when saving images. It also is used to start
the decode process.

Open Audio File...
Selects an audio file for subsequent decoding. Decoding will start automatically as long as
Disable auto-decode is not selected in the Options menu. Audio input files may be in either
AU (.au), WAVE (.wav), or raw (8-bit unsigned or 16-bit signed LSB) format. The files must
be encoded in linear PCM format at 11025 samples per second. Either 8, 16, or 32 bits per
sample is acceptable, but 8 bits per sample recordings do not contain enough information to
produce good quality images. 16 bits per sample is highly recommended. Audio files should
be mono. If a stereo (or multi channel) audio file is used the program will ignore all but one
channel. It is strongly recommended that only mono audio files are used.

Open Raw Image...
WXtoImg can read raw images in PNG, PBM (PGM), or NOA formats. This considerably
speeds up the processing time over reading in the audio files. Decoding will start automatically
as long as Disable auto-decode is not selected in the Options menu. NOA format files are
produced by some satellite receiving systems. These images should generally be 16 bit raw
grayscale images. Images in JPEG, BMP, AVI or other formats cannot be read by WXtoImg.
Note that the Resync, Interpolate, and Disable PLL options and the sampling rate settings
have no affect when processing these images. These settings apply only when audio files are
decoded.

Save Image as...
Saves the currently displayed image. The output format (JPEG, PNG, BMP, PNM, AVI) used
for output is specified by the filename extension. If you do not use an extension, or the exten-
sion does not relate to one of the supported output formats, the default will be the format set in
the Image and Movie Options... under the Options menu.

Composite Image to...
Saves the currently displayed image to the file given. If the current file exists and you over-
write it, then (similar to the AVI transparency) the file will be updated so that the original
image will only be overwritten where the current image contains valid satellite data. By select-
ing a projection other than Normal, and setting the Projection Options to a wide area around
your location, an image using multiple satellite passes may be built up.

Save Raw Image as...
Saves the 16 bit raw image in PNG format. Raw images are useful as they can read using
Open Raw Image... and can be processed to produce all the different enhancements. Note that
the Resync, Interpolate, and Disable PLL options and the sampling rate settings have no
affect when processing raw images.

Mixer Control...
Launches the mixer control used to select the input source, and recording and monitoring vol-
umes when recording.

Record... Starts the recording process. Allows selection of whether the image should be decoded, and
whether the audio file and/or raw image should be saved. Also allows for a series of images or
movies to be created. These settings are also used for the Auto Process command. The options
for which enhancements should be generated and the filenames for images and movies can be
set by clicking on the associated settings buttons. See the Filename Template section for a
description on how filenames are chosen. Other aspects of the recording process (e.g. bits per
sample) and whether recording is squelch or satellite pass based can be changed under
Recording Options... in the Options menu. The recording (and decoding) process repeats
until it is stopped by selecting Stop from the File menu. The Minimum percent of projection
filled setting (upgraded versions only) disables the saving of images and adding of movie
frames where the resulting image has less than the selected percent of pixels filled. Note that
images are never sav ed if the projection had no pixels filled. The default is 0.1%. The
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Minimum solar elevation for visible images setting (upgraded versions only) disables the sav-
ing of images which make use of visible light sensors on the satellite and where the centre pass
solar elevation is less than the setting. The default of 0 specifies that images should be saved
regardless of the solar elevation.

Record only (show image if enabled)
Records satellites according to the settings in Recording Options under the options
menu. An unprocessed image will be shown while recording if enabled in GUI
Options. Does not perform additional processing. These recordings may be later
decoded by using Open Audio File under the File menu or by clicking on the
thumbnail in the Audio Files tab.

Record and auto process
Records satellites according to the settings in Recording Options under the options
menu. After recording, the audio is decoded and displayed using the settings
under the Enhancements, Options and Projection menus. A number of options can
be enabled to create a set of images, add frames to animations, create composite
images, and create web pages (see FAQ for detailed information on creating web
pages). These settings are also used by the Auto Process command in the File
menu. Additionally, the audio file and/or the map file (generated for map over-
lays) may be removed after processing is complete.

Decode Starts the decode process. Decoding is automatically started after a file is opened or the direc-
tion or enhancement is changed. The automatic decoding may be disabled by selecting Dis-
able auto-decode in the Options menu. Manual starting of the decode process is always
required after any options under the Options menu have been changed, or when the Satellite
has been changed.

Partial Decode
Similar to Decode but the cut start (how many seconds into the file to start decoding) and
length (how many seconds of the file to decode) may be specified. This is useful when a
recording contains signals from two or more satellites. It is also useful as a way to crop the
image, by decoding only the good portion of the image. When text overlays are enabled, this
has an advantage over using the Crop command from the Image menu because text overlays
will be correctly positioned in the final image.

Auto Process
Builds and saves the images and adds frames to movies according to the Record settings (under
the File menu). Note that this processing will not remove the audio nor map files even if those
options are selected in the record settings.

View Image...
Allows viewing of images. Files in PNG, JPEG, BMP or PBM (PGM/PPM) format can be
viewed. The image transformations under the Image menu can be used to edit the images.
Enhancements and options are not applicable to these images (use Open Raw Image instead).
Images can be saved using the Save Image as... dialog under the File menu. In addition, for
images produced by WXtoImg, the image may be geometrically transformed using the projec-
tions under the Projection menu.

View Movie...
Allows viewing of AVI animation. Under Windows, Direct X version 8.0 or above must be
installed (note that for XP users Direct X will already be installed). Direct X can be obtained
from:

http://www.microsoft.com/directx

Under *NIX xanim must be installed to view the AVI movies. It can be obtained from:
http://xanim.va.pubnix.com/home.html
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Publish Web Page
Manually publishes (via FTP) the current web page. This does not add an image to the web
page. It is useful when Automatically FTP web page to server is not selected in Web Page Set-
tings under Record in the File menu and is typically used to transfer the web page manually
over a dial-up Internet connection.

Image Properties...
Displays a window showing information about the image being displayed.

Processing Info...
Displays a window showing all the information which appeared on the bottom status line dur-
ing the processing of the image.

Update Keplers
Uses the Internet to connect www.celestrak.com and download the latest orbital elements for
weather satellites. Orbital elements need to be updated regularly to use the overlay and pass
based recording options. Out-of-date keplers will cause the registration on overlays to be sig-
nificantly off. It is recommended that the keplers be updated at least weekly if overlays are
being used. For very accurate overlay placement, daily or even twice daily updates are recom-
mended.

Pass List... Displays a list of satellite passes that are scheduled to be recorded from the current time until
the indicated time ahead (default 1 week). The pass list displays only those satellites selected
in Active APT Satellites under the Options menu. It is also affected by the Recording Options.

Clear Closes any image being viewed and clears the display. Note that WXtoImg does not prompt to
save the image since the image can be re-generated from the original WAVE or raw image
later.

Stop When recording or decoding, this stops the recording or decoding process before it completes.

Exit,Quit Terminates the program. On MacOS X, the Quit command can be found under the WXtoImg
menu.

Direction Menu
This menu is available only if expert mode is enabled (see Options -> GUI Options). Sets the direction of
the pass for polar orbiting satellites. This setting is ignored when processing WEFAX images. The setting
is also ignored if the map and projection support (GUI Options under the Options menu) is enabled since
the program will determine the direction.

Autodetect Uses the last modification time of the input file to make a guess at which direction the
satellite was traveling. This option will fail to work correctly if the computers time zone
is not set correctly, the clock is off significantly, or if the station is too near to one of the
poles. Also this requires that the timestamp on the file represents the time of the satellite
pass.

South->North Northbound (ascending) pass. Satellite is moving from the south to the north. In this
case the image is rotated 180 degrees. For combined NOAA APT images, the image is
subsequently shifted 1/2 it’s width so that the channel A and B images remain on their
original sides of the combined image.

North->South Southbound (descending) pass. Satellite is moving from the north to the south.

Satellite Menu
Selects the satellite to decode. Under normal circumstances, for polar orbiting satellites, this should be set
to Autodetect APT. For geostationary satellites choose either GOES, Meteosat, or GMS. Only in special
circumstances (when receiver control is not available and multiple satellites are overhead and the wrong
satellite was recorded, or when decoding old audio files created by other programs with inaccurate dates or
times), should the specific satellite be selected. The specific satellite options are available only if expert
mode is enabled (see Options -> GUI Options).
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Autodetect APT
Autodetect is limited to checking for APT images from polar orbiting satellites. This speeds
up the detection process.

Meteosat Decodes WEFAX images from Meteosat geostationary satellites.

GOES Decodes WEFAX images from NOAA geostationary satellites (GOES). GMS Decodes
WEFAX images from GMS geostationary satellites.

Autodetect Autodetect attempts to determine the satellite using signal and image processing. This option
is available only if expert mode is enabled (see Options -> GUI Options).

Autodetect WEFAX
Autodetect is limited to checking for WEFAX images from geostationary satellites. It is much
better to select the specific geostationary satellite (GOES, Meteosat), rather than use this
option. This option is available only if expert mode is enabled (see Options -> GUI Options).

NOAA Decodes APT images from NOAA polar orbiting satellites (POES). This option is available
only if expert mode is enabled (see Options -> GUI Options).

Meteor (series 3)
Decodes APT images from the Russian Meteor Series 3 satellites. This option is available only
if expert mode is enabled (see Options -> GUI Options).

Meteor (series 2)
Decodes APT images from the Russian Meteor Series 2 satellites. This option is available only
if expert mode is enabled (see Options -> GUI Options).

Resurs Decodes APT images from the Russian Resurs satellites. This option is available only if expert
mode is enabled (see Options -> GUI Options).

Okean Decodes APT images from the Russian Okean satellites. This option is available only if expert
mode is enabled (see Options -> GUI Options).

SICH Decodes APT images from the Russian SICH satellites. This option is available only if expert
mode is enabled (see Options -> GUI Options).

NOAA 12 Decodes APT images from NOAA polar orbiting satellites (POES) and sets the sea surface
temperature calibration to NOAA 12. If the Sea surface temp enhancement is not being used,
this option is equivalent to NOAA. This option is available only if expert mode is enabled (see
Options -> GUI Options).

NOAA 14 Decodes APT images from NOAA polar orbiting satellites (POES) and sets the sea surface
temperature calibration to NOAA 14. If the Sea surface temp enhancement is not being used,
this option is equivalent to NOAA. This option is available only if expert mode is enabled (see
Options -> GUI Options).

NOAA 15 Decodes APT images from NOAA polar orbiting satellites (POES) and sets the sea surface
temperature calibration to NOAA 15. If the Sea surface temp enhancement is not being used,
this option is equivalent to NOAA. This option is available only if expert mode is enabled (see
Options -> GUI Options).

NOAA 16 Decodes APT images from NOAA polar orbiting satellites (POES) and sets the sea surface
temperature calibration to NOAA 16. If the Sea surface temp enhancement is not being used,
this option is equivalent to NOAA. This option is available only if expert mode is enabled (see
Options -> GUI Options).

NOAA 17 Decodes APT images from NOAA polar orbiting satellites (POES) and sets the sea surface
temperature calibration to NOAA 17. If the Sea surface temp enhancement is not being used,
this option is equivalent to NOAA. This option is available only if expert mode is enabled (see
Options -> GUI Options).
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Enhancements Menu
The Enhancements menu provides a wide range of enhancements. Changing the enhancement will auto-
matically start the decode process unless Disable auto-decode is selected in the Options menu.

Normal Produce a normal image, using Gamma, Sharpening, Despeckling, etc settings.

Pristine Produce pristine output (best representation of original digital data). Typically used to
output images for further processing by other software Pristine images are unenhanced,
but unlike raw images have been normalised to produce images which represent, as best
as the software is able to, the original digital data. No attempt is made to temperature
normalise IR images. Disables gamma, sharpening, rotation, despeckling, and other
enhancements.

Contrast enhance
Contrast enhancement is performed as per the Contrast setting in the Options menu.

Black and white Creates a black and white image, setting darker pixels to black and lighter pixels to
white.

Contrast enhance (NOAA ch A only)
Contrast enhancement is performed only on the NOAA channel A image as per the Con-
trast setting in the Options menu. The other image is not shown.

Contrast enhance (NOAA ch B only)
Contrast enhancement is performed only on the NOAA channel B image as per the Con-
trast setting in the Options menu. The other image is not shown.

MCIR map colour IR (NOAA)
Colours the NOAA sensor 4 IR image using a map to colour the sea blue and land green.
High clouds appear white, lower clouds gray or land/sea coloured, clouds generally
appear lighter, but distinguishing between land/sea and low cloud may be difficult.
Darker colours indicate warmer regions.

MSA Multispectral analysis (NOAA-# 2-4)
Multispectral analysis. Uses a NOAA channel 2-4 image and determines which regions
are most likely to be cloud, land, or sea based on an analysis of the two images. Pro-
duces a vivid false-coloured image as a result. There are several options which affect
colouring of these images in Image and Movie Options... under the Options menu. This
enhancement does not use a palette nor is it temperature normalised.

MSA with precipitation (NOAA-# 2-4)
Same as MSA multispectral analysis, but high cold cloud tops are coloured the same as
the NO enhancement to give an approximate indication of the probability and intensity
of precipitation.

MSA anaglyph false 3-D (NOAA-# 2-4)
Same as MSA multispectral analysis, but creates a 3-D anaglyph image (must be viewed
with red/blue glasses). Operational only if the software has been upgraded.

HVCT false-colour (NOAA 2-4)
Similar to HVC (below), but with blue water and with colours more indicative of land
temperatures.

HVCT with precipitation (NOAA 2-4)
Same as HVCT false-colour, but high cold cloud tops are coloured the same as the NO
enhancement to give an approximate indication of the probability and intensity of precip-
itation.

HVC false-colour (NOAA 2-4)
Creates a false colour image from NOAA APT images based on temperature using the
HVC colour model. Uses the temperature derived from the sensor 4 image to select the
hue and the brightness from the visible (sensor 2) image (or the sensor 4 image if the
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Use other sensor option is selected) to select the value and chroma. The HVC colour
model attempts to ensure that different colours at the same value will appear to the eye to
be the same brightness and the spacing between colours representing each degree will
appear to the eye to be similar. Bright areas are completely unsaturated in this model.

Sea surface temp (NOAA-# 3-4)
Creates a false colour image from NOAA APT images based on sea surface temperature.
Uses the sea surface temperature derived from the sensor 3 and 4 images to colour the
image. No attempt is made to distinguish cloud or land from sea. The sea surface tem-
perature may be incorrect due to the presence of thin or small clouds in the pixel evalu-
ated, or from noise in the signal. The sea surface temperature calibration requires
knowledge of the specific NOAA satellite. When using this enhancement, the specific
NOAA satellite should be chosen from the Satellite menu. The temperature displayed
on the status line will use the sea surface temperature algorithm to calculate the tempera-
ture only when this enhancement is used.

Daylight sea surface temp (NOAA)
Creates a false colour image from NOAA APT images based on sea surface temperature.
Uses the sea surface temperature derived from just the sensor 4 image to colour the
image. This is less accurate than the sea surface temperature derived from sensor 3-4
sea enhancement, but is available when the 3-4 image is not available. No attempt is
made to distinguish cloud or land from sea. The sea surface temperature may be incor-
rect due to the presence of thin or small clouds in the pixel evaluated, or from noise in
the signal.

Ve getation (NOAA 1-2)
Requires the rarely available NOAA APT sensor 1 and 2 images (seen during the test
phase after satellite launch). A vegetative index is built up and this is used so that land
will be coloured green, water dark blue, and clouds white. No palette is used for this
enhancement and the output is not temperature normalised.

Anaglyph false 3-D (GOES/NOAA)
Creates a false 3-D image (must be viewed with red/blue glasses) of the visible (sensor
2) image (or the sensor 4 image if no visible image is available) by estimating cloud
height. Operational only if the software has been upgraded.

Colour anaglyph false 3-D (NOAA)
Creates a false colour 3-D image based on the HVCT enhancement (must be viewed
with red/blue glasses) using the visible and far-IR images of the NOAA satellite (or just
the far-IR image if no visible image is available). Operational only if the software has
been upgraded.

Class enhancement (NOAA)
Unsupervised classification of NOAA APT images using an iterative optimisation clus-
tering algorithm. Uses an initial 27 cluster centres spaced equally along the two-dimen-
sional diagonal. The classification is used to tint the histogram equalised channel A
image.

NO colour IR enhancement (GOES/NOAA)
NOAA colour IR contrast enhancement option. Greatly increases contrast in the darker
land/sea regions and colours the cold cloud tops. Allows fine detail in land and sea to be
seen and provides a very readable indication of cloud top temperatures. This enhance-
ment option is temperature normalised.

ZA general IR enhancement (GOES/NOAA)
NOAA general purpose meteorological IR enhancement option. Increases contrast by
saturating the very low and very high temperature regions where there is typically very
little information. This enhancement option is temperature normalised.
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MB thunderstorm (GOES/NOAA)
NOAA cold cloud top enhancement option. Useful for showing where the strongest
rainfall is occurring in thunderstorms. This enhancement option is temperature nor-
malised.

MD warm season MB (GOES/NOAA)
The NOAA MD enhancement is a modification of the popular, general use MB enhance-
ment scheme. It is intended for warm season use, and provides improved enhancement
within the gray "step wedges" that depict "warm top" convection. An additional
improvement is better delineation of warm low clouds (30C to 7C). The middle cloud
range is somewhat broader than the MB, and enhancement of details is minimised. Oth-
erwise, it is the same as the MB enhancement. This enhancement option is temperature
normalised.

BD hurricane (GOES/NOAA)
NOAA hurricane enhancement option. Highlights certain temperatures in the eye and
eye wall of the storm system which are known to be related to the intensity of the hurri-
cane. This enhancement option is temperature normalised.

CC enhancement (GOES/NOAA)
NOAA CC enhancement curve. This enhancement option is temperature normalised.
This option is available only if expert mode is enabled (see Options -> GUI Options).

EC enhancement (GOES/NOAA)
NOAA EC enhancement curve. This enhancement option is temperature normalised.
This option is available only if expert mode is enabled (see Options -> GUI Options).

HE western US (GOES/NOAA)
The NOAA HE enhancement is used principally by weather offices in the western
United States. It provides good enhancement of a wide variety of cloud types, but is
somewhat complex, and may be difficult to use at first. It enhances low and middle level
clouds common along the Pacific Coast of North America in two separate gray shade
ranges. The freezing level is easily determined, an advantage for aviation users con-
cerned with icing. Step wedge regions display very cold infrared cloud top temperatures
associated with thunderstorms and frontal systems in 5 degree increments down to -60 C.
Tw o additional "repeat gray" segments define cloud top temperatures colder than -60C.
This enhancement option is temperature normalised. This option is available only if
expert mode is enabled (see Options -> GUI Options).

HF new western US (GOES/NOAA)
The NOAA HF enhancement is the most current of the "H" series of enhancements, and
is used principally by weather offices in the western United States. It provides good
enhancement of low and middle level clouds common along the Pacific Coast of North
America. Step wedge regions display very cold infrared cloud top temperatures associ-
ated with thunderstorms and frontal systems in 5 degree increments down to -60 C. Tw o
additional "repeat gray" segments define cloud top temperatures colder than -60C. This
enhancement option is temperature normalised. This option is available only if expert
mode is enabled (see Options -> GUI Options).

JF simple sea surface/cold cloud (GOES/NOAA)
The NOAA JF enhancement is a hybrid enhancement scheme used to highlight both sea
surface temperatures, and cold cloud tops associated with thunderstorms and other
weather systems. It is somewhat simpler to interpret than the later JJ enhancement. The
coldest portion of the enhancement (less than -33C) is nearly identical to the general-use
MB enhancement. Maximum enhancement is provided at the warm end (25 to 10C) to
depict sea surface temperatures and warm low clouds in tropical and sub-tropical areas.
This enhancement option is temperature normalised. This option is available only if
expert mode is enabled (see Options -> GUI Options).
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JJ sea surface/cold cloud (GOES/NOAA)
The NOAA JJ enhancement is used to highlight both sea surface temperatures, and cold
cloud tops associated with thunderstorms and other weather systems. Maximum
enhancement is provided at the warm end (23 to 0C) to depict sea surface temperatures
and low clouds. The presence of a freezing level break point is important for aviation
users interested in icing conditions. Multiple, steep, ramp enhancement ranges provide
considerable detail within cold cloud tops such as thunderstorms, but it is difficult to
determine the actual temperatures with any accuracy. This enhancement option is tem-
perature normalised. This option is available only if expert mode is enabled (see Options
-> GUI Options).

LC fog/low cloud/precip (GOES/NOAA)
The NOAA LC curve is used on images from the 3.9 micron shortwav e infrared channel
(CH2) of GOES. It provides maximum enhancement in the temperature range where fog
and low clouds typically occur (36C to -9C). Another enhanced thermal range is from
-10C to -29C, the region of precipitation generation in mid-latitude weather systems.
Since CH2 is sensitive to "hot spots," a steep, reverse ramp is found at the warm end
(68C to 50C) to show any observable fires as white. There is no enhancement at the very
cold end (-30 to -67C), due to the instrument noise normally present at these tempera-
tures. This enhancement option is temperature normalised. This option is available only
if expert mode is enabled (see Options -> GUI Options).

TA enhancement (GOES/NOAA)
NOAA TA enhancement curve. This enhancement option is temperature normalised.
This option is available only if expert mode is enabled (see Options -> GUI Options).

WV water vapour (GOES/NOAA)
The modified NOAA WV curve is used for the 6.7 micron water vapor channel (CH3) on
GOES. The only temperature range that is enhanced is between -5C and -90C. Temper-
atures colder than -90C are shown as white, and temperatures warmer than -5C are dis-
played as black. This enhancement option is temperature normalised. This option is
available only if expert mode is enabled (see Options -> GUI Options).

Options Menu
Selects a variety of options. The factory default settings for all the on/off options in this menu is off. For
Gamma, Sharpen, Despeckle, etc. the factory default setting is indicated by an asterisk; a plus indicates an
alternative recommended setting.

Disable auto-decode
If selected, this option prevents WXtoImg from starting an automatic decode whenever the
enhancement or direction is changed.

Interpolate If selected, enables interpolate and oversample (50% larger images). Creates larger images by
increasing the sampling rate in the horizontal and interpolation in the vertical. In the case of
NOAA images the Channel B image is also shifted down to compensate for the satellite
movement and the sampling method. This provides better registration between the images and
thus improves image quality in multispectral transformations. This option is available only if
expert mode is enabled (see Options -> GUI Options).

Use other sensor
The HVC and HVCT enahancements normally require one of the channels to be a visible light
sensor. By setting this option, the enhancement will make use of the far-IR sensor when no
visible sensor is available.

Disable PLL
If selected, disables the phase locked loop code used to ensure the image is not bent due to
doppler-shift nor slanted due to slight variations in sampling rate. This option is sometimes
useful with recordings from scanners to disable the burst PLL on Meteor and Resurs satellites
which can cause problems when decoding very poor quality signals.
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Show All If selected, disables the normal cropping of noisy/low signal portions of the image. See also
Crop telemetry which crops the sides of the image. This option is available only if expert
mode is enabled (see Options -> GUI Options).

Crop telemetry
If selected, crops the telemetry lines from the sides of the image. See also Show All which dis-
ables the automatic cropping of the top and bottom of the image.

Resync If selected, enables attempts to resync image. If enabled WXtoImg attempts to correct for miss-
ing time in the input audio file, however with low S/N ratios or from recordings made by too
narrow IF bandwidth receivers (scanners), this may cause false corrections to be made resulting
in very broken images. This option will create problems in a large percentage of otherwise
good images and should almost never be enabled by default. This option is available only if
expert mode is enabled (see Options -> GUI Options).

Disable Map Overlay
If selected, disables the overlaying of maps on the image. Overlaying maps requires the
keplers to be up-to-date. See Update Keplers in the File menu. Disabling map overlays does
not disable map generation. See Enable map and projection support in GUI Options.

Noise filter If selected, enables the noise filter. This is a 5x5 median edge-preserving image filter. Causes
significant blurring of the image. This option is available only if expert mode is enabled (see
Options -> GUI Options).

Contrast Allows selection of the contrast enhancement used within the HVC, HVCT, MSA, and veg
enhancements. Operational only if the software has been upgraded. Select either Hist Eq for
histogram equalisation, Linear (constant) for a constant linear enhancement which varies only
according to the satellite sensor, Linear (variable) for variable linear enhancement which is
adjusted for every image, or None to disable any contrast enhancement. If images are going to
be later compared or combined than either Linear (constant) or None should be used as all
images are treated in exactly the same way with these options.

Illumination Compensation
Illumination compensation corrects for the uneven lighting of the earth’s surface by the sun.
Full compensation corrects each image so that the earth’s surface appears to be lit from directly
overhead. High, Med and Low compensation apply some compensation, but do not fully cor-
rect. None performs no compensation. Note that with low sun angles compensation can dra-
matically increase the effects of noise in the signal.

Gamma The default gamma correction to apply. Typically between 1.00 and 2.50. A value of 1.00 dis-
ables gamma correction. For PC displays a gamma of about 1.40 seems to be optimal for
viewing, for Macintosh systems 1.15, for SGI systems 1.10, for NeXT systems 1.00, and for
Sun and other systems 1.40 is recommended.

Sharpen Set sharpening factor. The default is 0.6.

Despeckle Enables removing of random noise in the image. If expert mode is enabled (see Options ->
GUI Options), then the despeckling threshold may be set. To disable despeckling use none.
The threshold is the number of standard deviations the pixel in question can vary from the
mean of the other pixels in a 5x5 area surrounding it before it is considered noise and is
replaced by the mean value. Increasing sigma decreases the number of pixels which will be
replaced, decreasing sigma increases the number of pixels which will be replaced. The default
is none, a  value of 2.0 is recommended in most circumstances (this is the value used if
despeckle is enabled in non-expert mode). Lower values will cause significant blurring of the
image.

Active APT Satellites
Allows selection of the active APT satellites. The Active APT Satellites dialog controls which
satellites maps may be created for and which satellites will be recorded if the Record only
when active APT satellites are overhead option is checked in the Recording Options dialog.
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Also allows setting of the satellite frequency (MHz) used when control of the receiver’s chan-
nel is enabled. A priority can also be set. When two or more satellites are overhead then the
satellite with the highest priority (1=highest, 5=lowest) will be recorded. If the satellites have
the same priority, then the satellite with the highest maximum elevation will be recorded. Pri-
ority has no effect if receiver control is not enabled in the Recording Options. If Update this
table when updating Keplers is selected, then the software will select the active satellites and
set their frequencies (priorities will not be changed) according to the currently active satellites
(downloaded via the Internet). Enabling Expert mode in GUI Options allows no longer trans-
mitting satellites to be selected.

Ground Station Location
Allows setting of the ground station location. Latitude and longitude should be entered in
degrees and fractions of degrees and not in degrees, minutes, and seconds (north and east
should be entered as positive numbers, south and west should be entered as negative numbers).
If you enter the name of a large city (population 100,000 or more) and the country (e.g. United
States, United Kingdom), you can set the latitude and longitude automatically by clicking the
Lookup Lat/Lon button. This must be set if map overlays are being used or if the Record only
when active APT satellites are overhead option is checked in the Recording Options dialog.
Alternatively, you can check the Use GPS box, and set the serial port the GPS is connected to.
You must also set the baud rate (use 4800 if unsure). On your GPS you will have to enable
NMEA output (at the same baud rate) as this will not be enabled by default. Check the GPS
manual for instructions on how to do this. While this option is enabled, WXtoImg will check
the GPS for position information when needed. The GPS option is available only on upgraded
copies. You can also keep the PC clock set using the GPS by checking the Set PC clock from
GPS box. For this to work it requires your GPS to support NMEA 2.x. Note that WXtoImg
uses WGS84 datum for position, projections, and map overlays. On Linux you’ll have to run
the command /usr/sbin/visudo as root and add a line to the bottom similar to myusername
myhostname = NOPASSWD: /bin/date. Where myusername is your user name and myhost-
name is the computer’s hostname (run hostname to get the hostname if unsure).

Internet Options...
WXtoImg requires up-to-date Keplers to build map overlays and predict satellite passes. You
can choose to obtain the Keplers from Celestrak or Space Track. Celestrak only has a tempo-
rary permit to distribute Keplers, so it is highly recommended that a username and password
from Space Track is obtained from:

http://www.space-track.org/

Once you receive your password, you will need to login to the Space Track website and change
your temporary password, then select Get Keplers from Space Track and enter your username
and password.

On Windows XP and Windows Server 2003, you can configure the Internet time server set-
tings. Enabling this will ensure maps are aligned accurately.

Recording Options...
Used to select the recording mode and options.

Record using WEFAX start/stop tones (for geostationary satellites on 1.6GHz)
If selected then recording starts when the WEFAX start signal from a geostation-
ary satellite (i.e. GOES, Meteosat, or GMS) is hear. Recording stops when the
WEFAX stop signal is heard.

Record when 2400 Hz carrier present (do not use)
It is highly recommended that you do not use this option! If selected then record-
ing starts when a 2400 Hz carrier is heard. Generally this option is useful on APT
receivers without squelch control on the audio out (e.g. the RX2). Recording con-
tinues until the carrier drops out for finish recording delay seconds. This option is
available only if expert mode is enabled (see Options -> GUI Options).
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finish recording delay
Audio files are recorded until the carrier has dropped out the finish recording delay
time in seconds. For APT a good choice is 60 seconds, but for WEFAX 6 seconds
may sometimes work (a much better recording mode would be Record using
WEFAX start/stop tones). The factory default is 60. This option is available only
if expert mode is enabled (see Options -> GUI Options).

Record when sound level rises/squelch breaks (do not use)
It is highly recommended that you do not use this option! If selected then record-
ing occurs only when the volume is above the sound trigger level. Recording
stops after the volume has dropped for longer than finish recording delay seconds.
Generally this option is only useful on receivers with squelch control on the audio
out (e.g. PROscan, most scanners). This option is available only if expert mode is
enabled (see Options -> GUI Options).

sound trigger level
Sound trigger level (0 - 100). Recording occurs whenever the squelch is broken
by a passing satellite and the sound rises above the sound trigger level. Decreas-
ing the level makes recording more sensitive, increasing the level makes recording
less sensitive. The factory default is 25. This option is available only if expert
mode is enabled (see Options -> GUI Options).

finish recording delay
Audio files are recorded until the signal has dropped out the finish recording delay
time in seconds. For APT a good choice is 60 seconds, but for WEFAX 6 seconds
may sometimes work (a much better recording mode would be Record using
WEFAX start/stop tones). The factory default is 60. This option is available only
if expert mode is enabled (see Options -> GUI Options).

Record only when active APT satellites are overhead
If selected, then recording occurs only when a satellite is passing overhead which
is selected in the Active APT Satellites dialog in the Options menu and also meets
the conditions below. This is the default. This recording mode is the most effi-
cient and uses the least CPU since it does not need to continuously decode the
audio signal.

with maximum elevation above (degrees)
Only satellites where the maximum elevation (above the horizon) is equal to or
better that the value here will be recorded. The factory default is 20.

record only when satellite is above (degrees)
Waits until the satellite is above the horizon by this number of degrees before
recording and stops recording when the satellite falls below this number of
degrees. The factory default is 8.

and require Allows an optional additional check before recording is started. If squelch break
is selected then the program waits for the volume to rise above the sound trigger
level before recording. If 2400Hz carrier is selected then then the program waits
for a 2400 Hz carrier to be detected before recording starts. If either of these
options is selected then the finish recording delay is also used, but recording will
stop earlier if the satellite falls below the value set in record only when satellite is
above. If nothing is selected, then the program will record while the satellite is
overhead whether a signal is detected or not. The factory default is 2400Hz car-
rier.

soundcard Allows selection which soundcard should be used for recording. Default on Linux
is "/dev/dsp" (additional soundcards are named "/dev/dsp1", "/dev/dsp2", etc.). On
DOS and Windows the default is 0 (additional soundcards will be numbered 1, 2,
etc.).
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sample bits Allows selection of 8 or 16 bit recordings. 16-bit recordings produce the best
quality images, but 8-bit recordings reduce the size of the recordings by half. 16
bit recordings are highly recommended. The factory default is 16. This option
can only be changed if expert mode is enabled (see Options -> GUI Options).

sample rate Nominal sample rate. Must be 11025 samples per second.

receiver type Setting for computer control of receiver channel. Set to none if the receiver does
not support computer control or is not connected to the computer. Control only
occurs if the recording mode is set to Record only when active APT satellites are
overhead. If using PCR100 or PCR1000, ensure you have set the
PCR100/PCR1000’s internal jumper for line out as discussed in the
PCR100/PCR1000 manual before using this control. Kenwood receiver control
operates at 4800 baud default. AR3000, AR5000, and AOR receiver control oper-
ates at 4800 baud default. BC245XLT, BC895XLT and BC780XLT receiver con-
trol operates at 9600 baud default. IC-R8500 and IC-R10 use 9600 baud default
and addresses 4A and 52 respectively. Use External to run the external command
wxctl (wxctl, wxctl.com, wxctl.exe, or wxctl.bat) for control (passed the satellite
name as argument 1, the frequency in MHz as argument 2, and the receiver port as
argument 3; satellite name will be an empty string and frequency will be 0.00
when no channel is selected -- generally the control program should enter scan
mode but this is optional).

receiver port The RS-232 port used for computer control of the receiver channel. If the control
is not via RS-232 (e.g. the game port) this setting is ignored.

receiver baud Sets the baud rate to communicate with the receiver. If the receiver baud rate can-
not be changed, this setting will have no effect. Use receiver default to select the
default baud rate for the receiver.

Map Overlay Options...
Allows selection of which features and what colours they appear on the map overlays.

Te xt Options...
Allows text to be displayed on the image. Operational only if the software has been upgraded.
There are two text areas. To enable either or both select the associated Enable box. The text
may contain percent sequences that will be expanded as described in Filename Template below.
The colour may selected from the list and the default size (in points) selected from the list.
The position on the image may be specified using X: and Y:. The value may be c for centre, or
a positive number for the number of pixels from the left or top edge, or a negative number for
the number of pixels from the right or bottom edge. The text box can contain multiple lines. A
line can start with fontsize=##, to set a different font size (in points) for the line and any subse-
quent lines. The TrueType Font allows the selection of an alternative true type font. Leave this
blank to use the supplied font. An alternative font can be used to provide text overlays for
European and Asian languages as the built-in font supports only the standard ASCII (English)
characters.

Projection Options...
Allows for the control of projections. Operational only if the software has been upgraded.

Reference Latitude
The map projection will be centered at this latitude. Use negative numbers for
south, positive for north. Note that this is not the centre of the image but the cen-
tre of the projection itself (if in doubt leave this field blank).

Reference Longitude
The map projection will be centered at this longitude. Use negative numbers for
west, positive for east. Note that this is not the centre of the image but the centre
of the projection itself (if in doubt leave this field blank).
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North Boundary (latitude)

South Boundary (latitude)
If the boundaries are specified then the resulting image will will be cut off at these
boundaries and will not show points outside. Will not function unless all four
boundaries are given. Use negative numbers for southern hemisphere. Should be
between 90.0 and -90.0.

West Boundary (longitude)

East Boundary (longitude)
If the boundaries are specified then the resulting image will will be cut off at these
boundaries and will not show points outside. Will not function unless all four
boundaries are given. Use negative numbers for west, positive for east. Should be
between -180.0 and 180.0.

Scale (norm 1.0) or output width
Sets the scale or output width for the projection. Scale is a relative value which
defaults to 1.0. A value of 0.5 will result in an image half the width and half the
height. A value of 2.0 will result in an image twice as wide and twice as high.
There is no best value, but large or small values may result in a loss of image qual-
ity. Values greater than 50 are assumed to be the required output width in pixels
(rather than a relative scale). Values of scale greater than 2.0 are not supported,
and values for output width less than 50 are not supported.

Sampling Frequency...
This option is available only if expert mode is enabled (see Options -> GUI Options). Sam-
pling rates can be much more easily and accurately set using Slant Correction in the Image
menu. Allows manual setting of the sample rate. Try varying the sample rate from the normal
by 5 samples per second at a time (so if you have 11025 samples per second audio files try,
11020, 11030, 11015, 11035, 11010, 11040, etc) until the image is reasonably vertical, then
adjust by 1 or 2 samples per second until the PLL locks and the image becomes exactly verti-
cal. Determination of the sound cards sample rate normally needs to be done only once. A
setting of 0.0 indicates that the default sample rate should be used.

Image and Movie Options...
Used to set a variety of options relating to image and AVI output.

Default Image Format
Set the default image format to one of JPEG, PNG, BMP, PBM
(PGM/PPM/PNM), or AVI. This is used when auto saving images. Normally,
WXtoImg uses the filename extension (one of .png, .bmp, .pbm, .pgm, .ppm, .pnm,
.jpg, .jpeg, or .avi in lower or upper case) to determine the output file type, when
the Save Image as... item from the File menu is selected. If the output file exten-
sion is not specified or the output extension does not indicate a known format, then
the default image format is used to set the file type.

Default for Anaglyphs
Set the default image format for anaglyphs to one of JPEG, PNG, BMP, PBM
(PGM/PPM/PNM). This is used when auto saving images. Note that anaglyphs
are best saved in a lossless image format (PNG, BMP, or PPM) as the colour shifts
caused by JPEG encoding can affect 3-D viewing.

Default for Composites
Set the default image format for composite images to one of JPEG, PNG, BMP,
PBM (PGM/PPM/PNM). This is used when auto saving images. Note that com-
posite images are best saved in a lossless image format (PNG, BMP, or PPM)
because multiple overlaying of the composite image can compound the loss of
image quality inherent in JPEG images.
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JPEG Quality Sets the quality for JPEG images. The factory default is 65. The valid range is 0
to 100. See Image Output Formats for discussion.

HVC Palette Allows selection of the palette for the HVC enhancement. PNG, BMP and PPM
format files are supported. See the -P option in the wxtoimg command line man-
ual for the technical details. If left blank, then the default HVC palette is used.

Sea Surface Temp Palette
Allows selection of the palette for the Sea Surface Temperature and Daylight Sea
Surface Temperature enhancements. PNG, BMP and PPM format files are sup-
ported. See the -P option in the wxtoimg command line manual for the technical
details. If left blank, then the default Sea Surface Temp Palette is used.

MSA Sea to Land It is highly recommended that you do not change this option. Multispectral analy-
sis sea to land adjustment. The factory default value is 50. This should be
decreased if land in multispectral analysis enhancements appears blue, and
increased if water appears green. The valid range is 0 to 100. This option is avail-
able only if expert mode is enabled (see Options -> GUI Options) and should
really never be changed.

MSA Land to Cloud
It is highly recommended that you do not change this option. Multispectral analy-
sis land to cloud adjustment. The factory default value is 50. This should be
decreased if cloud in multispectral analysis enhancements appears green and
increased if land appears gray or white. The valid range is 0 to 100. This option is
available only if expert mode is enabled (see Options -> GUI Options) and should
really never be changed.

AVI Codec The compression method to use for AVI animations. Currently three types are
supported: MJPG, JPEG, and RGB. MJPG (Motion JPEG) provides for excellent
compression, JPEG provides somewhat less compression (and may be less stan-
dardised), RGB does no compression at all. Under BeOS JPEG is recommended
(as there are no available MJPG decoders), under all other operating systems
MJPG is the recommended choice (MJPG decoders for Windows are available in
the DirectX package). The JPGQ and lJPGS codecs are provided for backward
compatibility and will be dropped in a future release.

AVI Transparency
Enables transparency on AVI images so that if the pixels in the current frame are
not set the pixels from the previous frame will be used. Better results may be
achieved by increasing the AVI Quality or using the RGB AVI Codec. The factory
default is enabled.

AVI Quality Sets the quality for AVI animations. The factory default is 20. The valid range is
0 to 100. See Image Output Formats for discussion.

AVI Max Frames The maximum number of frames in the animation. If, after adding the new image,
the number of frames in the animation exceeds this number then frames will be
dropped from the beginning so that the total number of frames is AVI Max Frames.

AVI Frame Rate The rate at which to display the animation in frames/second. Normally values
between 0.2 (1 frame every 5 seconds) and 8.0 (8 frames per second) are useful.
The factory default is 1.0.

AVI Scale Reduce output animations by fact factor. Factor should be between 0.0 and 1.0.
The factory default is 0.5.

File Names and Locations...
Sets the locations for opening and saving files.
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Audio file naming
Audio file names are the time of the recording. You can change audio file name
format to some other time format. Beware that this setting also affects how
WXtoImg determines when a file was recorded. Selecting Other will prevent
WXtoImg from using the filename to determine the time of recording (and audio
files will be recorded as MMDDHHMM UTC time.

Filename Template
Used to define the default output filename, and the filename for raw files used
when recording. If left blank, then this defaults to the input filename or when
recording to %T. See Filename Template section for details.

Use for audio recordings/maps too
If selected, the audio recordings and any overlay maps will be renamed to match
the template after decoding. Note that if a no decode option is selected when
recording then the audio recordings/maps will not be renamed to use the the tem-
plate.

Audio File Location
The folder/directory in which audio files will be saved when recording/decoding.
Also the default location when opening audio files.

Raw Image Location
The folder/directory in which raw images will be saved when recording. Also the
default location when opening/saving raw images.

Save Image Location
The default location when saving processed/enhanced images using the Save
Image as... option under the File menu.

Map File Location
The folder/directory in which map files will be saved when recording/decoding.

Thumbnail Location
The folder/directory in which thumbnail images will be saved.

GUI Options...
Allows setting of operations that affect the graphical user interface (GUI).

Temperature units
When temperature is shown, this indicates what units should be used. Degrees
Celsius, Fahrenheit, or Kelvin may be chosen. The factory default is Celsius.

Distance units Allows the selection of miles (mi), nautical miles (nm), or kilimoters (km) where
WXtoImg shows distances. The factory default is km.

Help Language Select EN (English), ES (Spanish), DE (German), JA (Japanese), or PL (Polish)
for the help language. Translations for most languages are not yet available. If
you can help in translation for any of these or other languages contact us at
http://www.wxtoimg.com/email.html .

Help Font Size Allows the font size for help text to be made larger or smaller. +0 is the default
size, negative numbers use smaller than normal fonts, positive numbers larger than
normal fonts.

Date/time format Allows selection of the date and time format where WXtoImg displays dates and
times. Operational only if the software has been upgraded.

Show time as UTC
If enabled times will be shown in UTC, if disabled, local time will be shown.
Operational only if the software has been upgraded.

version 2.7.3 16



WXTOIMG(GUI) WXTOIMG(GUI)

Enable map and projection support
By default this is enabled, but on very slow processors disabling this can speed up
image generation by disabling support for map overlays, projections, good quality
MSA (multi spectral analysis enhancements), MCIR enhancements, and illumina-
tion compensation. Because of the significant impact on the use of MSA and
MCIR enhancements and on other WXtoImg features, it is strongly recommended
that this feature be left enabled. This option is available only if expert mode is
enabled (see Options -> GUI Options).

Flip Meteor series 3 images
If selected then images from Meteor series 3 will be automatically flipped. This is
useful if map and projection support is disabled and Meteor 3 is in a phase where
all the images are being presented upside down. The factory default is off. This
option is available only if expert mode is enabled (see Options -> GUI Options)
and is of little use since the failure of Meteor 3-21.

Use private colormap
If the display has only 256 Colors (8 bit), then when this is selected (the factory
default) a new colormap will be installed. This provides for the full 256 colours to
be used by WXtoImg itself (instead of being shared with all other applications and
the operating system). This setting should have no effect on High Color (15 or 16
bit) or True Color (24 or 32 bit) adapters. The options must be saved and the pro-
gram exited and restarted before any change will take effect. This option is avail-
able only if expert mode is enabled (see Options -> GUI Options).

Tear off menus If enabled, then next time program is started menus can be torn from the applica-
tion (by selecting the dashed line at the top of the menu). This will place the menu
in a separate window which can be moved around the screen. This allows for eas-
ier selection of enhancements and options. Operational on Windows and Linux
platforms only and only if the software has been upgraded.

Status info text size
Allows you to change the size of the text on the status lines at the bottom of the
main window and the info line above the main image. The default is Normal.
This options is only available on Windows platforms.

Automatically enter record mode
If selected then when WXtoImg will automatically enter record mode as though
Record had been selected from the File menu and Record had been clicked. For
APT satellites, record mode is entered a few minutes before the next satellite pass
and exited after processing is complete. This mode is also useful to automate
recording/decoding when WXtoImg is started automatically. Operational only if
the software has been upgraded.

Disable sat position during record
Disables satellite position (elevation and azimuth) calculations and display while
recording a satellite passing overhead. This may be useful on slow computers to
help prevent breaks in the image caused by missing time in the recording.

Automatically update Keplers
If selected, then Keplers will be downloaded via the Internet approximately every
24 hours. Requires an "always-on", or automatic connection to the Internet.
Operational only if the software has been upgraded and if WXtoImg is being used
to record.

Auto-save options on exit
If selected then all options will be saved as if Save Options had be chosen just
prior to exiting the program. The factory default is on.
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Maximum number of thumbnails
Sets the maximum number of thumbnails that can be displayed on any of the
thumbnail pages. The most recent thumbnails are shown.

Enable Expert Mode
Enabled a set of mostly historical features, many of which have little use. Options
must be saved and the program exited and restarted before changes take effect.

Save Options
This saves all the options on the options menu (and options dialogs on the options menu) and
with the exception of Interpolate, Show All, Resync, and Disable PLL. This option also saves
the window size and position. Also the recording modes and image and movie settings are
saved. If this menu item is not chosen, then any changes made will not be restored when the
program is restarted (unless Auto-save options on exit is selected in the GUI Options dialog).

Projection Menu
The Projection menu supports changing the map projection used to display the APT satellite image. The
default normal projection is the unaltered space oblique projection the satellite provides.

Normal The unaltered space oblique projection that the satellite provides.

Mercator The classic Mercator projection. Lines of constant direction (rhumb lines) appear straight.
This cylindrical projection does not work at or near the poles, and displays considerable area
distortion away from the equator.

Equidistant Cylindrical
An equidistant cylindrical projection where the lines of latitude and longitude are parallel and
equally spaced. Sometimes called Plate Carree. Displays considerable area distortion near the
poles.

Equal-Area Cylindrical
An cylindrical projection where land masses of equal area have the same area. Displays con-
siderable shape distortion near the poles.

Eckert IV An equal-area projection with semi-circle meridians used for world maps.

Eckert VI An equal-area projection with sinusoidal meridians used for world maps.

Mollweide Another equal-area projection commonly used for world maps.

Miller A compromise cylindrical projection which shows less distortion than the Mercator but does
not show straight rhumb lines.

Polar Lambert Equal-Area
The Polar Lambert Azimuthal Equal-Area projection. An azimuthal projection similar to the
Polar Stereographic but which is equal area.

Polar Stereographic
An azimuthal projection where the lines of longitude converge at the poles.

Polar Azimuthal Equidistant
An equidistant projection centered at the poles.

Orthographic
A perspective projection from infinite distance.

Image Menu
Options which use the image or allow the image to be hand altered after processing.

Slant Correction...
After selection, a line may be dragged along a vertical edge to set the sampling rate. See the
Required Calibration... document under the Help menu for more details.

version 2.7.3 18



WXTOIMG(GUI) WXTOIMG(GUI)

Move Map Overlay...
After selection a line may be dragged between a point on the overlay and the corresponding
point on the image to adjust the position of the overlay.

Colour Negative
Creates a colour negative of the image. For grayscale images, black becomes white and white
black.

Warmer Colours
Warms the colours in the image by shifting the image toward the red end of the spectrum. The
effects can be quite subtle, so the command may have to be repeated before the effect becomes
noticeable.

Colder Colours
Cools the colours in the image by shifting the image to-wards the blue end of the spectrum.
The effects can be quite subtle, so the command may have to be repeated before the effect
becomes noticeable.

Convert to Grayscale
Converts the image to a grayscale image.

Histogram Equalise Image
The image is histogram equalised. Note that this operation operates on the entire 8-bit dis-
played image and so is inferior to using the histogram equalisation under enhancements (which
operates in 16-bits). However, it is quite useful for histogram equalising cropped or magnified
images.

Increase Contrast
Increases contrast in the image. Use multiple times to increase contrast more.

Flip Image Rotates the image 180 degrees.

White Background...
Sets the background on an image which has been geometrically transformed (i.e. the Projection
was set to something other than Normal), from black to white. This option does not work on
JPEG images viewed using View Image. See also White background on projections in Image
Settings under Record in the File menu for setting the background to white for automatically
saved images.

Shift Image...
After selection, a point on the displayed image may be selected which will be set as the new
left edge.

Crop Image...
After selection, by clicking and dragging a box, the region to be cropped may be selected.
Then clicking inside the box will crop the image; clicking outside the box will cancel the oper-
ation.

Rotate Image...
Allows the image to be rotated. After selection, drag a line from left to right. This line will
become horizontal in the rotated image.

Resize Image...
A sub-menu allows selection of the new size (as a percent of the original). The image can only
be reduced in size. The image can be reduced several times to create very small images.

Magnify Area...
A sub-menu allows selection of the degree of magnification (as a percent of the original).
After selection, by clicking and dragging a box, the region to be magnified may be selected.
Then clicking inside the box will cause that part of the image to be magnified; clicking outside
the box will cancel the operation. Magnification uses interpolation to minimise pixelation.
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View Enhancement Curve
Shows the current enhancement curve or palette for the selected enhancement in the Enhance-
ments menu. If the enhancement is a histogram equalisation enhancement, then the histogram
equalisation for the current image will be shown.

Undo All (Decode)
Does a decode, which has the effect of undoing all shift and crop operations.

Filename Template
The filename template specifies the output filename format. This can be found in File Names and Loca-
tions... under the Options menu. If the filename template is left blank it defaults to the original pathname.
The % sequences in the filename template are replaced as defined below. All replacements will be con-
verted to lowercase.

For example an Filename Template of:
%s-%T-%e

Could produce output filenames like:
meteor3-01061123-norm.jpg
noaa-12-01062348-msa.bmp
noaa-01062352-mcir-precip.png
noaa-01062350-raw.png
met7-01022603-norm.png

Templates may expand to create directories, for example:
%Y/%m/%d/%s-%e
%Y\%m\%d\%s-%e

under Linux/*NIX/MacOS X and Windows/DOS respectively.

%@ causes any time or date % sequences (either before or after the %@) to use local time rather
than UTC time.

%s is replaced with the satellite name in lower case (up to 8 characters, e.g. met7, noaa-14,
meteor3).

%N is replaced with the satellite name in mixed case and with spaces (e.g. MET7, NOAA 17,
Meteor 3-5).

%g is replaced with the satellite type in lowercase (e.g. met, noaa, meteor3).

%D is replaced with the satellite direction, either northbound or southbound.

%p is replaced with a single character abbreviation for the satellite direction, either N for north-
bound or S for southbound southbound.

%E is replaced with the maximum elevation for the pass in degrees (0-90).

%ˆ is replaced with the azimuth at maximum elevation for the pass in degrees (0-360).

%z is replaced with a single letter, either E or W to specify the azimuth is more easterly or more
westerly at maximum elevation.

%: is replaced with either east or west to specify the azimuth is more easterly or more westerly at
maximum elevation.

%f is replaced with the original audio input filename but without any folder or directory name nor
with any extension (e.g. if the input filename is /tmp/03042215.wav then %f is replaced with
03042215).

%F is replaced with the format (either apt or wefax).

%C is replaced with the WEFAX spectral band or NOAA APT channel a-channel b. Up to 3 char-
acters, e.g. WEFAX: vis, ir, nir; NOAA APT: 2-4, 3-4. If unknown will be replaced with
nothing.
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%e is replaced by the name of the enhancement (e.g. za, hvc) or raw for raw, pris for pristine,
norm for normal (no enhancement). With the histeq and norm enhancements, if only the A or
B channel is selected then the name of the enhancement is appended with a or b (e.g. histeqb,
contrasta, norma).

%l is replaced by the sector. Up to 4 character sector information from WEFAX digital headers.
If not available (or APT), will be substituted with nothing.

%8,9,10,11%
is replaced by the 9th, 10th, 11th and 12th characters from the WEFAX digital header (they
appear off by one because numbering starts at 0). The valid range of the numbers is 0 - 49
which corresponds to the 50 characters in the digital header. The numbers start at 0, are sepa-
rated by commas, and a % ends the sequence. If the character selected is a space (or is other-
wise not available) then nothing will be substituted (i.e. the resulting filename will not contain
space characters).

%r is replaced by the satellite radio frequency in MHz (e.g. 137.50).

%k is replaced by the date in YYMMDD format. For WEFAX this is the date embedded in the
digital header from the image. For APT the current UTC date is used. (Equivalent to
%y%m%d).

%K is the same as %k but in DDMMYY format (equivalent to %d%m%y).

%L is the same as %k but in MMDDYY format (equivalent to %m%d%y).

%d is replaced by the 2 digit day of the month (01-31).

%m is replaced by the 2 digit month (01-12).

%y is replaced by the year without the century (e.g. 01).

%Y is replaced by the year with the century (e.g. 2001).

%T is replaced by the date and time in MMDDHHMM format. For WEFAX this is the date and
time embedded in the digital header from the image. For APT the current UTC time is used.
(Equivalent to %m%d%H%M).

%t is replaced by the time in HHMM format. For WEFAX this is the time embedded in the digital
header from the image. For APT the current UTC time is used. (Equivalent to %H%M).

%H is replaced by the 2 digit hour (24-hour clock) (00-23).

%I is replaced by the 2 digit hour (12-hour clock) (0-12).

%P is replaced by the AM/PM designation.

%M is replaced by the 2 digit minute (00-59).

%Z is replaced by the timezone name or abbreviation.

%% is replaced by %.

Image Output Formats
Images may be produced in JPEG, PNG, BMP, PBM (PGM/PPM/PNM), or AVI format.

The output format: JPEG (.jpg), PNG (.png), BMP (.bmp), PNM (.pnm), or AVI (.avi) used for output is
specified by the filename extension. If you do not use an extension, or the extension does not relate to one
of the supported output formats, the default will be the format set in the Image and Movie Options... under
the Options menu.

JPEG files are a lossy compressed format. The quality (Image and Movie Options under the Options menu)
can be varied to control the amount of detail preserved and the amount of compression. Quality can vary
from 0 to 100. The useful range is probably 30 to 95 where a quality of 30 produces a well compressed
image (although lacking in much detail and with some significant artifacts), whereas a quality of 95 pro-
duces a very good image, but with little compression. JPEG cannot support 16 bit grayscale images. JPEG
images can contain comments.
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PNG files are a compressed lossless image format. Due to having good compression and being lossless
they are the preferred format. PNG supports 16 bit grayscale images, comments, and records gamma.

BMP files are an image format widely used on PC based systems. The BMP files produced by WXtoImg
are not compressed. BMP files cannot support 16 bit grayscale images, nor can they contain comments.

PBM files are an uncompressed image format but well suited to further processing and display on *NIX
systems. PBM (bitmap) files are also called PPM (colour), PGM (grayscale), and PNM (any). They sup-
port 16 bit grayscale images and comments.

AVI files are animated sequences of images. AVI files support different types of compression, RGB which
is uncompressed, JPEG which uses JPEG compression, and MJPG (or Motion JPEG) which uses a special
abbreviated form of JPEG compression. The type of compression used in the AVI file is controlled with the
configuration file parameter AVI Codec. For JPEG and MJPG the AVI quality (Image and Movie Options
under the Options menu) will control the quality of the AVI animation. AVI files use a lower default quality
to achieve better compression. Because of the motion, lower image quality is needed. When you select an
AVI file for output, if the file exists, the new image will be added to the end of the sequence. If the AVI file
does not already exist then a new AVI file will be created with only the new image. If the AVI file already
contains the maximum number or greater of frames (images) in the sequence then the first frame (or
frames) will be removed so that the total number of frames will be the maximum after the new image is
added.

Volume Control
When recording signals it is important that the volume is not set too high or too low. If the volume is set
too high, clipping will occur and detail will be lost in the white areas of the image. If the volume is set too
low, some detail will be lost throughout the image.

The volume should be adjusted so that the vol which is displayed when the signal is processed is between
about 50.0 and 75.0. Higher numeric values of vol (e.g. 92.3) indicate that the volume should be decreased,
lower numeric values of vol (e.g. 24.7) indicate that the receiver volume should be increased.

The volume will be displayed when a signal is being recorded. The volume on the receiver can be easily
adjusted during a satellite pass to set a reasonable vol. Note that it is not recommended that the volume be
changed during every satellite pass (as the resulting images will show bands of light and dark). The volume
should be set once and then left alone.

If using 8-bit audio files, the volume should be slowly increased until the vol shows between about 85.0 and
92.0. Unfortunately, each satellite will require a different optimal volume setting. Results will never be as
good as images created from 16-bit recordings, especially where any of the image enhancements are used.

If the volume is set very high, WXtoImg may issue a warning message.

Equipment Required
In order to make use of this program for APT transmissions you will need a receiver capable of receiving
FM signals in the 137-138MHz band (look for satellites at 137.30, 137.40, 137.50, 137.62, 137.80, and
137.85 MHz). A purpose designed weather satellite receiver is the best option as the sensitivity and IF
bandwidth (about 50kHz) will be correct.

Scanners and general purpose communications receivers can be used, however these often have a very nar-
row IF bandwidth (close to 15kHz) with the result that whites (above about 128 on a scale of 0-255) invari-
ably will be noisy and clipped. The narrow bandwidth will also cause a lot of noise except when the satel-
lite is straight overhead as the doppler-shift combined with the narrow IF bandwidth will result in a very
poor signal. However, the upgraded versions of WXtoImg adjust the frequency to compensate for doppler
shift on supported receivers with an RS-232 connection. Some communications receivers have a 30kHz
(acceptable if the frequency is adjusted using an upgraded version of WXtoImg) or 50kHz IF filter option,
and there are modifications for a few scanners to increase the IF bandwidth. A pre-amp can help with the
poor sensitivity, but these modifications may not result in the same image quality as a purpose designed
weather satellite receiver.

The upgraded versions of WXtoImg also contain special code to much more accurately build colour
enhancements when using narrow bandwidth receivers. The upgrade will be of considerable benefit to
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those getting reasonable images when using the Contrast enhance (NOAA ch B only) enhancement.

A special antenna will be needed regardless of which receiver you have available. You can build an antenna
and there are several designs for the highly recommended QFH antenna available on the Internet. Turnstile
and crossed dipole antennas are other options.

You will, of course, need an audio cable between the "speaker out" of your receiver and the "line in" on
your sound card.

Finally, it may help to know when the polar orbiting weather satellites are passing overhead, so you might
want to obtain a tracking program. However, in record mode WXtoImg will let you know the next satellite
pass is expected.

For WEFAX transmissions from geostationary satellites, the most common method is to use a small
parabolic dish antenna, coupled with an active feed and down converter to convert the 1600 MHz band sig-
nal to the 137 MHz band. Then the same receiver can be used for these satellites. See references for more
information.

References and more Information
Paul Hayes has information on building a QFH antenna at:

http://homepage.ntlworld.com/phqfh1/qfh_diy_guide.htm

Also check out the information and FAQ on the WXtoImg home page at
http://www.wxtoimg.com/

Known Bugs
The resync option for correcting missing intervals in the recording does not always work and may work
incorrectly.

Auto detection of Okean satellites does not usually work. Select Okean under the Satellite menu before
Decoding recordings from these satellites.

Triggering on Okean satellites is not available resulting in curved images due to doppler shift and a need to
have accurately adjusted the sample rate to match the soundcard on these and Meteosat satellites.

Terms and Conditions
The WXtoImg programs (which include wxtoimg, xwxtoimg, wxrec, wxmap, wxproj, and wxbatch) and
documentation are not warranted to be free of bugs. You should backup your system before installing this
software. Because of the nature of the analog signals and complex processing performed do not expect
results of this program to be correct in any or every instance.

The WXtoImg programs and documentation are supplied "AS IS". Abstract Technologies New Zealand
Limited disclaim all warranties, expressed or implied, including, without limitation, the warranties of mer-
chantability and of fitness for any purpose. Abstract Technologies New Zealand Limited assume no liabil-
ity for direct, indirect, incidental, special, exemplary, or consequential damages, which may result from the
use of the WXtoImg programs, even if advised of the possibility of such damage.

The WXtoImg programs and documentation are not intended to be used where life, health, safety, or prop-
erty may be at risk.

The freeware edition of the WXtoImg software may be used for personal, non-commercial purposes free of
charge. Additional features are available only to those who upgrade their copies of the software.

Use by any commercial organisation, or any individual for commercial purposes requires the purchase of a
professional edition upgrade key. An upgrade key may be obtained from:

Abstract Technologies New Zealand Limited
P.O. Box 113-126
Auckland
New Zealand
Fax: +64-9-309-6047
Email: http://www.wxtoimg.com/email.html
http://www.wxtoimg.com/reg/
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The WXtoImg programs and documentation may only be redistributed for personal use, on a non-commer-
cial basis, and in their original, unmodified packages. No other redistribution is permitted. Abstract Tech-
nologies New Zealand Limited reserves the right to stop redistribution. Upgrade keys may be used only on
a single computer and may not be produced, distributed or disclosed to other parties. You may not disas-
semble, reverse engineer, decode or decrypt this software or make use of information, code or algorithms
obtained in this way.

The WXtoImg programs are Copyright (c) 2001-2005 Abstract Technologies New Zealand Limited. All
rights reserved.

Credits
Special thanks to Andreas Rehberg, Gerd Berg (DK1RR), John Boudreau, Adrian Chamberlain, Ari
Ervaskivi, Jakub Gorzynski (SQ2WB), Les Hamilton, Paul Hayes, Paul Holder, Nakato Mikiya, Pauli
Nunez (EA3BLQ), Andre Phillips, Jeremy Royle, Hartmut Schaksmeier and many others who beta tested
the numerous early versions of this software.

NOAA provided a wealth of information on their web-site and in their publications, developed most of the
enhancement curves used in WXtoImg, and provided outstanding support.

Notices
Copyright (c) 2001-2005 Abstract Technologies New Zealand Limited. All rights reserved.

The ZA, MB, MD, BD, CC, EC, HE, HF, JF, JJ, LC, TA, WV, and NO enhancement curves were provided
by the National Oceanic & Atmospheric Administration (NOAA).

JPEG support, in part, provided by the Independent JPEG Group.

Te xt overlay support based on the work of the FreeType Team.
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Calibration
WXtoImg must be setup and calibrated to achieve useful results. Setup requires setting the location of your
receiver and downloading the latest Keplers. Calibration must be performed in two areas: the first is the
volume of the recording, the second is to match the sampling frequency to the sound card sample rate. You
need to perform this calibration only once.

Before you Begin
Simply connect your receiver’s audio output to the line input of your soundcard using a suitable cable. If
you have an ICOM PCR1000 receiver, ensure that you follow the instructions in the manual for setting the
internal jumper for line level output.

The polar orbiting satellites transmit on 137.10, 137.40, 137.50, 137.62, or 137.9125 FM (50kHz or NFM)
and each satellite will pass by twice per day (about 12 hours apart) at roughly the same times each day.
You may be able to catch lower elevation passes about 1.5 hours before and after the best pass. Note that
all satellites will not be transmitting depending on on time of year, the time of day, their proximity to other
satellites, and whether they are working or not. A good pass lasts approximately 10 to 15 minutes. When
WXtoImg is in record mode it will indicate the next satellite pass and the frequency on which it is transmit-
ting.

Setting the Ground Station Location
Select Ground Station Location from the Options menu. Enter the name of your city and country. If the
city you live in has a population over about 100,000 then click on the Lookup Lat/Lon button. If you are at
sea, you can enter any description you like for city and country.

If you could not lookup the latitude and longitude, then you’ll have to enter the latitude and longitude of
your location. Latitude and longitude must be entered in degrees and fractions of degrees (e.g. 52.500, not
52:30, nor 52:30:00, nor 52:30.00). North and east should be entered as positive numbers, south and west
should be entered as negative numbers. If you do not know the latitude and longitude of your location, then
try the closest large city (population >100,000) and click on Lookup Lat/Lon. If you do not know the alti-
tude just enter 0.0.

Updating the Keplers
Current U.S. government regulations mean you should obtain an account from Space Track to gain access
to the Keplerian elements required for WXtoImg. However, at present you can use Celestrak without an
account (see Options -> Internet Options). Accounts are generally simple and fast to obtain from:

http://wwww.space-track.org/
Once you obtain an account, you will need to login to this account and change your password. Then open
Internet Options from the Options menu, and type in your Space Track username and new password.

Now, connect to the Internet and select Update Keplers from the File menu to download the latest orbiting
elements for the weather satellites. If you do not have an Internet connection, then ignore this and instead
select Disable Map Overlay from the Options menu.

Checking for Satellite Passes at Your Location
Select Satellite Pass List from the File menu. This will display a list of satellite passes from the current
time to 7 days ahead for your location. Times are given in both local time and UTC.

Adjusting the Volume
Set the volume control on your receiver to a low to moderate level, then select Mixer Control... from the
File menu. Configure the mixer to take input from the source the receiver is plugged into (normally the
Line In), set the PCM and Recording (cassette) levels (Linux only) all the way to the top. Set the Line level
(Linux and Windows) at about the mid-point. Set the igain (Linux only) to it’s mid-point. It is better for
the volume and line levels to be too low than too high to start with.

Under Windows 95 you may have to select Properties from the Options menu on the Mixer control and
check the Recording button, and check the Line volume control before you can adjust the controls as above.

Select Record... from the File menu, and click on Auto Record.

Wait for a satellite to arrive. WXtoImg will indicate when the satellite is expected (in UTC) and on what
frequency the satellite is transmitting in the status bar.
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WXtoImg will record the pass -- during the pass an image may be shown, do not be concerned with the
brightness or darkness of the image or other problems such as it consisting only of diagonal lines. When
setting the volume never use this image as a guide -- use only the volume setting discussed below. After
recording is complete WXtoImg will build a map and re-decode the image. It does this to produce the best
possible results.

Av oid using the scrollbars to scroll the image while recording -- this can cause the resulting image to be
split.

The program volume (vol) will be displayed when the signal is being recorded. If a satellite is passing
overhead and the status line indicates that the program is still waiting for carrier or waiting for signal then
the receiver volume may be too low or the mixer input level may be set too low. Slowly increase either or
both until the status line indicates the signal is being recorded. The volume on the receiver (or the record-
ing level on the mixer) can then be easily adjusted during the pass to set a vol between 50.0 and 75.0. If the
receiver has no volume control or the volume control does not affect the speaker output, then adjust the
mixer settings (recording, igain, or input line level) until the displayed vol is between about 50.0 and 75.0.
The volume bar should be green when a signal is being received, red or yellow indicates the volume is too
high or too low.

The image will be re-decoded after the satellite has passed. When the decode is complete, the overall vol-
ume will be shown on the right hand side of the status line below the image.

The overall volume should be between about 40.0 and 85.0. Higher numeric values of vol (e.g. 90.2) indi-
cate that the volume should be decreased, lower numeric values of vol (e.g. 24.7) indicate that the volume
should be increased.

If the volume is set too high, clipping will occur and detail will be lost in the white areas of the image. If
the volume is set too low, some detail will be lost throughout the image.

Except for this calibration, avoid adjusting the volume when the satellite is passing overhead. Adjusting the
volume during a pass will produce banding in the final image and will adversely affect temperature calibra-
tion.

Adjust the volume appropriately and repeat.

Adjusting the Sampling Frequency (Slant Correction)
Start by selecting Disable PLL from the Options menu. Next select Normal from the Projection menu.
You want this item to be selected and all the other items in this menu to be unselected. Disabling the PLL
allows us to more accurately set the sampling rate. Double check that Resync is not selected as if this
option is enabled it will cause problems when the PLL is disabled.

Next, select a recording to decode. Select Open Audio File... from the File menu, and choose a recording.
Ideally you’d like a recording from a NOAA satellite (the resulting image has two side by side images) on a
high overhead pass.

Now, wait for the image to be decoded and displayed. The image will be bent slightly from top to bottom
as a result of the doppler shift. This is normal when the PLL is disabled.

Select Slant Correction... from the Image menu. Scroll to the top of the image and click on a vertical edge
in the image. Continue holding the button down and drag a line to the bottom of the image. Allow the
image to scroll until you get to the bottom of the image. Ensure the pointer is over the same edge that you
originally clicked on and release the button.

A dialog box will pop up and display the suggested sampling rate. The WXtoImg program can estimate the
sampling rates for all other satellites. You should select the Estimate and set sampling frequencies for all
satellites option if it is not already selected, then click on Set.

Un-select Disable PLL from the Options menu. The image will be re-decoded and should be completely
straight. If it is bent, ensure that you have un-selected Disable PLL in the Options menu. If it is slanted,
then try repeating the process, paying close attention to these instructions.

While options are (by default) saved on exit, you should ensure the sampling frequencies are saved by
selecting Save Options from the Options menu.

version 2.7.3 2



WXTOIMG(Calibration) WXTOIMG(Calibration)

You may obtain improved results by repeating this process for other satellite types but selecting the Set only
XXX sampling frequency option. This will likely need to be done for Meteosat and Okean satellites as these
require very accurate settings.

Copyright
Copyright (c) 2001-2005 Abstract Technologies New Zealand Limited. All rights reserved.
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Recording
Why do I get a message Warning: couldn’t find telemetry data when WXtoImg displays an image?
You need to adjust the sampling frequency. Information on adjusting the sampling frequency can be found
in the Required Calibration... document under the Help menu. Also see the Slant Correction section in this
manual.

Why do I get Error: waveInOpen failed! when WXtoImg tries to record?
Open Record Options in the Options menu, and change the soundcard (even if your PC only has one sound-
card you may need to change this for recording to work). Click OK and enter record mode again to test.
Try all soundcard values until you find one that works. If this fails to eliminate the problem you may need
to install or re-install the latest drivers for your soundcard.

Why does recording never start?
Ensure that the audio cable from the receiver is attached to the soundcard Line 1 input. Ensure that you
have used the speaker (and not line) output from the receiver. Follow the instructions carefully in the
Required Calibration... section under the Help menu.

Why is the image split (sometimes referred to as sync loss)?
The image looks as though it has been cut horizontally and the upper or lower portion shifted left or right.
This may occur in just one place or in multiple places in the image.

Firstly, it is important not to use the scrollbars to scroll the image as it is being recorded -- or to be careful
not to hold the mouse button down for more than a fraction of a second while scrolling.

More generally, this is caused by other programs running while WXtoImg is recording. Screen savers can
also cause this problem, so setting your screen saver to none would be a good idea. On slower computers
or where another program must be running at the same time, WXtoImg’s image display while recording can
create the problem. In this case you may want to disable image display while recording (and also other
processing), by un-selecting Show image while recording and selecting Disable sat position during record
in GUI Options in the Options menu.

Why does the program hang with a Status: opening soundcard... message?
The soundcard is in use by another program (possibly even the mixer). Close other programs (including the
mixer if it is running).

Why does recording start immediately and never stop recording when I try to record signals from
polar orbiting satellites?
Most likely your receiver does not have squelch on the audio out. Select either the Record when 2400 Hz
carrier present or Record only when selected active APT satellites are overhead mode.

Why does it never stop recording when I try to record signals from geostationary satellites?
You need to select the Record using WEFAX start/stop tones mode in the Recording Options... dialog under
the Options menu.

Why do I only record every other image from geostationary satellites?
Processing is taking too long. You can reduce processing time by disabling Options -> Despeckle (or set-
ting it to none). Despeckle is generally inappropriate on WEFAX images because it degrades the fine lines
in the maps. Setting Options -> Sharpen to none will marginally improve processing speed.

You can further reduce processing by setting Maximum number of thumbnails to 0 in GUI Options in the
Options menu.

Also ensure that you have not selected Use for audio recordings/maps too in File Names and Locations
under the Options menu. Renaming these files requires significant extra time. Finally reduce the number
of autoprocessing images and steps performed under Record in the File menu.

If your computer still isn’t fast enough to complete processing before the next image arrives consider
upgrading your computer. Alternatively you can select Record only (show image if enabled) from Record
under the File menu. In this mode, only audio files can be saved, but the program will show the image as it
is being recorded.

The program tries to record polar satellites at the wrong time, what needs to be done?
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Check your time and timezone setting are correct. On Windows open the Date/Time control panel (Start ->
Settings -> Control Panel -> Date/Time), ensure that the "Time zone" is for a nearby city, that "Automati-
cally adjust clock for daylight savings changes" is selected, and that the time is correct.

On Windows, check your autoexec.bat file for a setting starting with SET TZ=. This will override the time-
zone settings set in the Windows control panel and can cause problems for WXtoImg. Remove the line or
comment it out.

How can I automatically remove the older images and recordings?
Select Record from the File menu. There are separate options for when to remove audio files, raw images,
maps, and images. Choose a time for these to be deleted. Select Accept, then select Save Options from the
Options menu. Note that files are only deleted if they hav e been created automatically by WXtoImg. If
you use Save Image as or Save Raw Image as the files created will not be automatically deleted. Audio
files created by other programs will also not be deleted.

Image Slant
Why do I get a message Warning: couldn’t find telemetry data ?
You need to adjust the sampling frequency. Information on adjusting the sampling frequency can be found
in the Required Calibration... document under the Help menu. Also see below.

Why are my images slanted?
You need to adjust the sampling frequency. Information on adjusting the sampling frequency can be found
in the Required Calibration... document under the Help menu. Also see below.

I can’t find a vertical edge in the image to use for slant correction.
Ensure you have selected Disable PLL from the Options menu, and then selected Slant Correction from the
Image menu.

This is because your soundcard is sampling very far from the 11025 Hz that it should be. This isn’t a prob-
lem. Your image will have sloping horizontal lines running through it. Instead of dragging a line along a
vertical edge, just drag a line along one of the sloping (near horizontal) lines from left to right across the
image.

Next select Estimate and set sampling frequencies for all satellites and click on Set.

Choose Decode from the File menu and repeat the procedure. This time the edges should be near vertical.

Remember to ensure Disable PLL is not selected and then choose Save Options from the Options Menu to
save the slant correction settings.

Map Overlays
Can WXtoImg produce map overlays from recordings made by other programs?
Yes. However it may be necessary to change Audio file naming to Other, in the File Names and Locations
dialog under the Options menu. This often needs to be done even if the filenames are MMDDHHMM.wav
(month, day, hour, minute) because WXtoImg requires that this date be the time of the start of the recording
and not the time when the satellite came over the horizon.

Why do I not see map overlays and often get a message that WXtoImg could not find matching pass
to build overlay map ?
Ensure that you have set the latitude and longitude under Ground Station Location... in the Options menu
to match your location.

Also check that the appropriate satellite type is selected in the Active APT Satellites sub-menu in the
Options menu.

It could also be that your computer’s clock is off significantly (5 minutes or more). See Why are the maps
never aligned correctly below.

Finally, your timezone setting may be incorrect so that the calculation of UTC time will not be correct. On
Windows open the Date/Time control panel (Start -> Settings -> Control Panel -> Date/Time), ensure that
the "Time zone" is for a nearby city, that "Automatically adjust clock for daylight savings changes" is
selected, and that the time is correct.
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Note that the Ground Station Location, needed for generating maps, is not used in determining UTC time.

Why are the maps never aligned correctly?
The most common cause is that the computer’s clock is off by more than a 250ms (a quarter of a second).
In order for overlays to be aligned accurately the computer’s clock must be very accurately set. On Win-
dows XP and Windows Server 2003, WXtoImg can set the clock to an Internet time source. See Internet
Options in the Options menu. Upgraded versions of WXtoImg can synchronise the PC’s clock to a GPS. If
you are recording on a different computer, then the clock on the recording computer must be set correctly.

My clock is accurately set, what other causes are there?
Using out-of-date Keplers will also cause the maps to be incorrectly aligned. Just use the Update Keplers
option under the File menu.

Also if you use recordings that were copied from some other place, then the timestamp on the recording
may be affected resulting in maps which are significantly mis-aligned. Look for a copy program that pre-
serves time-stamps (under *NIX use cp with the -p option, or use mv instead).

What can I do about overlays that are still missing or not correctly aligned?
Use the Move Overlay... option under the Image menu to move incorrectly aligned overlays.

On Windows, check your autoexec.bat file for a setting starting with SET TZ=. This will override the time-
zone settings set in the Windows control panel and can cause problems for WXtoImg. Remove the line or
comment it out.

Check that your Internet firewall is configured to allow connections from WXtoImg (xwxtoimg.exe), so that
the Keplers can be updated.

Keplers
How often should I update the Keplers?
In order to avoid having to move the map overlay, Keplers should be updated every few days. Connect to
the Internet, then select Update Keplers from the File menu.

I cannot update the Keplers, what’s wrong?
Check your Internet connection. If it is OK and Update Keplers fails it is likely because your Internet fire-
wall is not configured to allow xwxtoimg.exe to make connections to the Internet (via HTTP port 80).
Check your Internet firewall manual for details.

I do not have access to the Internet, how can I update the Keplers?
If you have email access and can get the Keplers emailed to you or sent on floppy disk or other media, then
simply copy a file of two line elements into \Program Files\wxtoimg\weather.txt under Windows, or
˜/.wxtoimg/weather.txt under *NIX.

General
Why do I get the warning message enhancement ignored: could not find a NOAA sensor 2 (or 3)
image ?
The operational NOAA satellites send images from two sensors. At night, images from sensor 3 (mid/ther-
mal infrared) and sensor 4 (thermal infrared) are sent. During daylight (and dusk) sensor 2 (visible/near
infrared) and sensor 4 (thermal infrared) are sent. The warning indicates that the enhancement you have
chosen (from the Enhancements menu) requires a sensor which is not available in the current image. In this
case WXtoImg ignores the enhancement chosen and produces a "Normal" enhancement image instead.

How can I get images that show exactly the data that was received from the satellite?
Set Enhancement to Pristine and enable Show All in the Options menu. (You’ll need to enable expert mode
in GUI Options under the Options menu and restart WXtoImg to have the Show All option.)

Can I process old .WAV files from satellites that haven’t transmitted for a long time?
Yes. First enable expert mode in GUI Options under the Options menu. Exit WXtoImg and start it again.
Now select the satellite you wish to process the WAVE file for from the Satellite menu. Open the WAVE
file using Open Audio File in the File menu.

If the program fails to build a map, it is likely because the date/time stamp on the WAVE file is not correct.
You’ll need to ensure the file is named YYYYMMDDHHMMSS.wav for the UTC time it was recorded
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(i.e. 19990928025912) for 28 September 1999 02:59:12 UTC. Be as accurate as possible with the time, but
generally +/- 5 minutes will be OK (however you will have to move the map using Move Map Overlay from
the Image menu). Now open File Names and Locations from the Options menu and set Audio file naming
to YYYYMMDDHHMMSS UTC time. Click OK. Finally open your renamed file using Open Audio File.

Why are some menu items gray and not selectable?
These items are available only in the upgraded version. Information on upgrading is available at:

http://www.wxtoimg.com/reg/

Note that while in record mode or when images are being processed all of the options except Help, Stop,
and Exit are gray.

How do I display local time instead of UTC time?
This applies only to copies of WXtoImg with an upgrade key installed. Disable the Show time as UTC set-
ting in GUI Options in the Options menu.

To change time on the text overlays (only), Open Te xt Options from the Options menu. Replace UTC with
%@%Z or %@local or use %@ followed by your time zone (e.g. %@EST). Select OK.

Hints for improving image quality.
If you are using a narrow bandwidth scanner or communications receiver, then purchase an upgrade key,
open Recording Options, and set receiver type to Scanner or Communications. By doing this, the software
will use special processing modes to dramatically improve image quality with colour enhancements. If you
have a computer control cable for your receiver and the receiver is shown in the list, then select the specific
receiver instead. Even better images will be obtained when WXtoImg can control the receiver. Purchase
the upgrade only when you have clearly recognisable images using the Contrast enhance (NOAA ch B only)
option.

For APT images set Despeckle to 2.0 in the Options menu to help eliminate some of the random noise. For
WEFAX images Despeckle should usually be set to none.

On upgraded versions, set Minimum Solar Elevation for visible images to 15.0 in the Record dialogue in the
File menu.

Set Illumination Compensation to Full or Med or any other choice than None when Contrast is set to Linear
(constant).

If you are producing an image for printing, set Gamma to none in the Options menu, and save the file as a
PNG file (by placing

If you are creating movies/animations, etc AVI Codec to RGB in Image and Movie Options in the Options
menu. This will create much larger animations, but will greatly improve the quality. Note that you’ll have
to delete your existing animations before the change takes effect (the codec is only set when the animation
is created for the first time).

When using one of the Anaglyph enhancements from NOAA satellite passes at dusk or night, enable Use
other sensor in the Options menu. Also save your anaglyph images as PNG or BMP files (just use a .png or
a .bmp extension. This is usually necessary because the lossy JPEG format can cause colour shifts that
adversely affect the 3-D effect.

To remove the noisy portions of the image at the top and bottom, open the Recording Options... dialog in
the Options menu and select Record only when selected active APT satellites are overhead, then set record
only when satellite is above (degrees) to about 15. This will ensure that recording only takes place while
the satellite is at least 15 degrees above the horizon. Note that the best value will depend on your environ-
ment and receiving equipment (values between 8 and 18 would be typical).

How can I create images that I can import into Digital Atmosphere?
This applies to upgraded versions only. Enable DA compatible BMP format in Image and Movie Options in
the Options menu. Set Projection to Orthographic. Open Projection Options from the Options menu. Set
Scale to 640 (or if you’ve changed the map width use the width of your DA map is in pixels). Look at the
DA map and guess as closely as possible the most northern and southern latitudes and the most eastern and
western longitudes (in degrees and decimal degrees). Use these values (negative for south and west,
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positive for north and east) for the North, South, West, and East boundaries. Set the Reference Longitude to
the longitude at the centre of the DA map. Set the Reference Latitude to the latitude at the centre of the DA
map.

How do I print an image?
Because WXtoImg has no built in print facilities, you must first save the image to a file (select Save Image
As under the File menu). End the filename with .png or .bmp to create a PNG or BMP image rather than
the default JPEG (this will improve print quality). You may also want to set Gamma to none in the Options
menu before saving the image. Once the image has been saved you can open it with a variety of programs,
including photo editors or your Internet browser and print it.

Why do the colours on my screen go strange when I run WXtoImg?
This is because you have a graphics adapter set to 256 Color (8-bit) mode. WXtoImg grabs all 256 colours
for it’s own use -- which allows it to display much better images. You could try changing the display set-
tings to True Color (24 or 32 bit) or High Color (15 or 16 bit). If your display adapter is not capable of
more than 256 colours and you really dislike this feature, it can be disabled by un-selecting Use private col-
ormap, under GUI Options in the Options menu. Remember to Save Options, then exit and restart the pro-
gram.

What does northbound 51 W mean?
This is a description of the satellite pass. Southbound or northbound indicates the direction the satellite is
traveling. The maximum elevation (in this case 51 degrees) is given next. Note that the maximum ele-
vation will be between 0 and 90 degrees (with 90 indicating a direct overhead pass). This is followed by an
either E (east) or W (west) to indicate if the satellite is traveling to the east or west of you (at the time of the
maximum elevation).

I just want a nice false coloured image. How do I do that?
During the summer when images are well illuminated by the sun, the MSA Multispectral analysis, HVC,
and HVCT enhancements on NOAA satellites give good results. Select these under the Enhancements
menu.

During the winter or summer, day or night, the MCIR and NO enhancements on NOAA satellites gives
good results.

What does WXtoImg mean?
WXtoImg is shorthand for "WX to image" (weather satellite to image).

AVI Animations
Can I build movies from polar orbiting satellites?
Yes, if you have purchased the upgrade. Here’s how to do it:

First, open the Recording Options dialog from the Options menu. Select Record only when selected active
APT satellites are overhead. Select OK.

If you wish to create animations of the HVC, HVCT, or Anaglyph enhancements select the Use other sen-
sor in the Options menu (this allows images to be added during the day and night, otherwise the animation
will contain only images from day-time passes).

Open the Image and Movie Options... dialog under the Options If you would like high quality movies or
wish to view 3-D movies using one of the Anaglyph enhancements you might want to change the AVI
Codec to RGB. (This will result in movies which are very large, but will provide a better 3-D effect.) Oth-
erwise use the MJPG codec. Select OK.

Open the Record dialog from the File menu. Ensure that Record and auto process is selected. Ensure Cre-
ate Movie(s) is selected. Then click on the Movie Settings button.

Select the enhancements you would like for the movie. A movie will be made for each selected enhance-
ment. The best enhancements for AVI movies would be MCIR map colour IR (NOAA), Contrast enhance
(NOAA ch B only), Daylight sea surface temp, Anaglyph false 3-D, Colour anaglyph false 3-D, NO colour
IR enhancement, and ZA general IR enhancement. You may also get reasonable results with the HVC false-
colour and HVCT false-colour enhancements.
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Click on the Easy Set Defaults button.

Select Set.

Set the Minimum percent of projection filled to 50.0 so that frames with less than 50% of the pixels filled
will not be added.

Now click on the Record button. Each time a satellite passes a frame will be added to movie(s). You can
view the movies that have been produced by selecting View Movie from the File menu.

Can I build movies from a bunch of old images, raw images or recordings?
Yes, if you have purchased the upgrade and if using processed or raw images, the images were produced by
WXtoImg. Note that new contrast enhancements are available in WXtoImg v2.3 and above to improve
frame to frame image consistency. Movies made from images generated by older versions of WXtoImg
won’t be as good as those made from raw images or recordings.

Select Linear (constant) from the Contrast sub-menu in the Options menu. This helps to ensure that each
frame in the animation will have similar brightness and contrast.

Select Full from the Illumination Compensation sub-menu in the Options menu. This also helps to ensure
that each frame in the animation will have similar brightness and contrast.

If you wish to create animations of the HVC, HVCT, or Anaglyph enhancements you might want to select
the Use other sensor in the Options menu.

Open the Image and Movie Options... dialog under the Options menu. Change the AVI Scale to 1.000. (If
you wish to alter the size of the movie, use the Projection Scale in the Projection Options dialog under the
Options menu instead.) If you wish to view 3-D movies using the Anaglyph enhancement you might want
to change the AVI Codec to RGB. (This will result in movies which are very large, but will provide a better
3-D effect.) Otherwise use the MJPG codec. Select OK.

Open the Projection Options dialog from the Options menu. You can change the Centre Longitude if
desired to some longitude near you, or leave it blank. Now set the North, South, West and East boundaries.
Try setting them to about 10 degrees north, south, west and east of your location. Latitude and longitude
must be entered as a decimal number in degrees and fractions of degrees. Use positive numbers for north
and east, negative numbers for south and west. You must enter a value for all four bounds. Select Set.

Under the Projection menu, select Mercator (or any projection other than Normal).

Under the Enhancements menu, select then enhancement you want to use for the movie. The best enhance-
ments for AVI movies would be MCIR map colour IR (NOAA), Contrast enhance (NOAA ch B only), Day-
light sea surface temp, Anaglyph false 3-D, NO colour IR enhancement, and ZA general IR enhancement.
You may also get good results with the HVC false-colour and HVCT false-colour, and Ve getation enhance-
ments.

Now open a recording using Open Audio File, a raw image using Open Raw Image, or a processed image
using View Image from the File menu. When processing is complete, select Save Image from the File
menu. Save the file to an AVI movie by setting the filename extension to .avi (e.g. noaa-za.avi).

Repeat the previous step for other recordings, raw images, and movies, saving them to the same filename.
When prompted to overwrite the file, select yes. AVI movies are not overwritten, instead a frame will be
added to the end of the movie.

When you have added all the images, select View Movie from the File menu and select the file you just cre-
ated.

OK, but isn’t there an easier way to build many different AVIs from old images?
Yes. Follow the instructions for Can I build movies from polar orbiting satellites? but in the last step, click
on the Accept button rather than Record button.

Now open a recording using Open Audio File, a raw image using Open Raw Image, or a processed image
using View Image from the File menu. Once processing is complete, select Auto Process from the File
menu. Repeat.

I cannot display the AVIs using Windows Media Player.
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Unfortunately, older versions of the Windows Media Player do not support the MJPG (Motion JPEG)
encoding which is the default in WXtoImg version 1.0 and above. A special codec is needed for Windows
Media Player to play these files. You can get this MJPG codec by installing Microsoft Direct X version 8.0
or above. Available from:

http://www.microsoft.com/directx

Note that Windows 95 users must download a different version of Direct X, and Windows XP users do not
need to install this.

If you still have trouble, check your display settings (Start -> Control Panel -> Display -> Settings, or on
XP: Start -> Control Panel -> Appearance and Themes -> Display -> Settings) and set the colour quality to
32 bits or 24 bits.

Alternatively, the Apple Quicktime player for Windows works fine. It is available from:
http://www.apple.com/quicktime/download/

Finally, you could select Image and Movie Options... from the Options menu and set AVI Codec to RGB.
This will create very large uncompressed animations, but this format is supported by almost every AVI
viewer.

Note the Linux/*NIX xanim player supports the MJPG encoding method used.

Can I build movies of images from geostationary satellites?
Yes. Here’s how to do it:

First, open the Recording Options dialog from the Options menu. Select Record using WEFAX start/stop
tones. Select OK.

Select Linear (constant) from the Contrast sub-menu in the Options menu. This helps to ensure that each
frame in the animation will have similar brightness and contrast.

Open the Image and Movie Options... dialog under the Options menu. Set the AVI Scale to 0.500. Select
OK.

Open the Record dialog from the File menu. Ensure that Record and auto process is selected. Ensure Cre-
ate Movie(s) is selected. Then click on the Movie Settings button.

Set the Movie Filename Template to %s-%l-%C-%e.

Select the enhancements you would like for the movie. Only some of the enhancements apply to geosta-
tionary satellites. If in doubt, just select Normal. Select OK.

Now click on the Record button. Each time an image is decoded from the satellite it will be added to the
appropriate movie. A different movie will be created for each sector, each sensor and each enhancement.
You can view the movies by selecting View Movie from the File menu.

Composite Images
Can I automatically build combined images from multiple satellite passes?
Yes, if you have purchased the upgrade. Here’s how to do it:

First, open the Recording Options dialog from the Options menu. Select Record only when selected active
APT satellites are overhead. Select OK.

If you wish to create composite images using the HVC, HVCT, or Anaglyph enhancements you might want
to select the Use other sensor in the Options menu.

Open the Record dialog from the File menu. Ensure that Record and auto process is selected. Ensure Cre-
ate composite image(s) is selected. Then click on the Composite Image Settings button.

Select the enhancements you would like to create composite images for.

Click on the Easy Set Defaults button.

Select Set.

Note that the Minimum percent of projection filled does not apply to composite images.
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Now click on the Record button. Each time a satellite passes the images will be overlaid on the composite
images. You can view the composite images that have been produced by selecting View Image from the
File menu.

Can I build composite images manually?
Yes, if you have purchased the upgrade.

Select Linear (constant) from the Contrast sub-menu in the Options menu. This helps to ensure that part of
the composite image will have similar brightness and contrast.

Select Full from the Illumination Compensation sub-menu in the Options menu. This also helps to ensure
that each part of the composite image will have similar brightness and contrast.

Open the Projection Options dialog from the Options menu. You can change the Centre Longitude if
desired to some longitude near you, or leave it blank. Now set the North, South, West and East boundaries.
Try setting them to about 30 degrees north and south, and about 30 - 40 degrees west and east of your loca-
tion. Latitude and longitude must be entered as a decimal number in degrees and fractions of degrees. Use
positive numbers for north and east, negative numbers for south and west. You must enter a value for all
four bounds. Select Set.

Under the Projection menu, select Mercator (or any projection other than Normal).

Under the Enhancements menu, select then enhancement you want to use for the composite image.

Now open a recording using Open Audio File, a raw image using Open Raw Image, or a processed image
(from WXtoImg) using View Image from the File menu. Opening audio files or raw images will generally
result in better results. When processing is complete, select Composite Image to from the File menu. Bet-
ter results can be achieved by saving to PNG or BMP files (set the filename extension to .png or .bmp (e.g.
noaa-2401.png).

Repeat the previous step for other recordings, raw images, and movies, saving them to the same filename.
When prompted to overwrite the file, select yes. Composite images are not overwritten, instead the new
image will be overlaid over the previous one.

Better results may be achieved by saving the lower elevation passes first and the highest elevation pass last.
This ensures that the best images occupy as much of the composite image as possible.

When you have added all the images, select View Image from the File menu and select the file you just cre-
ated.

Creating Web Pages
Can I automatically create web pages and publish them?
Yes. Here’s how to do it:

Open the Record dialog from the File menu. Ensure that Record and auto process is selected. Ensure Cre-
ate web page is selected. Then click on the Web Page Settings button.

If you have purchased an upgrade key, leave the HTML Template alone for now.

Select the enhancement to use on the web page. When a list of enhancements is chosen, the first available
enhancement is used. If you select "MSA,MCIR,contrast", then if the MSA enhancement is available this
will be used, otherwise the MCIR enhancement will be used if available, otherwise just a contrast enhanced
image will be used.

Choose a thumbnail size. Using 20.0% is recommended, although in some cases you might find larger
thumbnails (25.0%) look better.

The HTML Filename is the name of the HTML file that will be created. If unsure, leave this as index.html.

Most Internet Service Providers (ISPs) provide free home page access. Check with your ISP about setting
up a home page if you are unsure. Your ISP should provide you with: the hostname for FTP access to your
home page (Hostname), a username or login for FTP access to your home page (User), and a password for
FTP access to your home page (Password). Enter this information in the locations provided.

For the Directory you should enter the directory where your web page should be placed. If the directory
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does not exist WXtoImg will attempt to create it. Your ISP may be able to help you choose the directory
name for use with FTP.

If you have an "always on" Internet connection, check the box Automatically FTP web page to server, this
tells WXtoImg to update your web page immediately and automatically after each satellite pass is decoded.
If you do not select this option you can manually publish your web page at any time by selecting Publish
Web Page from the File menu. You might want to un-check Place web page into folder, but there is no rea-
son you cannot do both.

Although this varies considerably from ISP to ISP, your web page may be accessed using a URL similar to
(replacing Hostname, User, and Directory):

http://www.Hostname/User/Directory/index.html
or

http://www.Hostname/˜User/Directory/index.html

Contact your ISP for more information about using FTP to load your own home page.

If you don’t want to publish the web page, you can create it in a folder or directory on your computer:

Ensure the the box Place web page into folder is checked.

Enter the folder where you would like the web page built, you can click the Browse button to select an
existing folder. The HTML Filename will be built in this folder (typically index.html).

After entering the FTP settings and/or the folder settings, select OK.

You should be back at the Record dialog. Ensure that "Create Image(s)" is selected. Now click on Image
Settings. In the Enhancements section you should select the enhancement(s) you chose for Enhancement to
use in the Web Page Settings.

Click OK.

Now click Accept.

Finally select Save Options from the Options menu.

Select Record from the File menu. Each time a satellite passes the images and thumbnails will be created
and a web page will be built.

How can I improve the quality of the images on my web page?
For the Enhancement to use (Web Page Settings, under Record in the File menu), select an option that
includes visible light imagery (e.g. MSA, MCIR, contrast).

Set the Minimum solar elevation for visible images setting (upgraded versions only under Record in the File
menu) to about 15 degrees. This will eliminate poorly lit visible images from being presented on the web
page.

If you have selected a projection other than Normal, set the Minimum percent of projection filled setting
(upgraded versions only under Record in the File menu) to about 66 percent. This will prevent images with
only a small fraction of the image filled from being presented on the web page.

Under Recording Options in the Options menu make sure Record only when selected active APT satellites
are overhead is selected. Set with maximum elevation above (degrees) to about 30 to prevent low elevation
passes from being recorded and presented on the web page. And set record only when satellite is above
(degrees) to about 15 to crop the noisy top and bottom sections of the image when the satellite is not high
enough to receive a good signal.

How can I present time as local time on my web pages?
If you have purchased the upgrade, open Web Page Settings from the Record dialog under the File menu.
Click the Browse button after HTML Template and select template2.html. Click OK, then click Accept.

If the time is also displayed on the images (text overlay), then open Te xt Options from the Options menu.
Replace UTC with %@%Z or %@local or use %@ followed by your time zone (e.g. %@EST). Select OK.

Can I change the web page layout, number of images, or information on the web page?
Yes, if you have purchased the upgrade. In Web Page Settings in Record under the File menu you will find
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an option for the HTML Template. This template is the HTML document used to create the web page. You
can try the other templates provided (note that the web page will not change until after the next satellite
pass).

Or you can create your own template. You may wish to look at the default (template1.html) document as a
guide. You can copy this file to another and edit it.

The web page, HTML filename, is created from the HTML Template by substituting text within the tem-
plate.

The text imageX.jpg will be replaced with the name of an image created by WXtoImg. thumbX.jpg will be
replaced with the name of the corresponding thumbnail. X should be a number 1 or greater. The most
recent image will be use X equal to 1. You should not leave any gaps in the image numbers. If you want 4
images on your web page then you should have references to image1.jpg, image2.jpg, image3.jpg, and
image4.jpg and likely the 4 corresponding thumbnails: thumb1.jpg, thumb2.jpg, thumb3.jpg, and
thumb4.jpg.

Information text about the satellite pass or ground station can also added to the web page. INFO(X,Y) in
the template will be replaced with the info corresponding to image X (as above the most recent image is 1).
Y is a number which indicates the
information desired (chosen from the list below). There can be no spaces in this string. E.g. INFO(2, 4)
will not be replaced. For Y=4 or Y=44 an optional extra argument can be used which specifies the
date/time format (e.g. INFO(1,44,%Y/%m/%d %H:%M %Z)).

Y Description
0 width of image (in pixels)
1 height of image (in pixels)
2 width of thumbnail (in pixels)
3 height of thumbnail (in pixels)
4 time of satellite pass (UTC)
44 time of satellite pass (local time)
5 satellite name (e.g. NOAA 17)
6 maximum elevation of satellite pass
7 azimuth at maximum elevation (E or W)
8 direction of pass (northbound, southbound)
9 enhancement used (e.g. MSA)
10 ground station location
11 latitude of ground station
12 longitude of ground station
13 frequency in MHz (e.g. 137.62)
14 projection name (e.g. Mercator)
19 wxtoimg version number (e.g. 2.4.15)
24 estimated time of publication (UTC)
64 estimated time of publication (local time)

To display information about future satellite passes on your web site you can use X=-1,-2... with X=-1
being the next satellite pass. Y=24 and Y=64 apply only to future satellite passes. The optional date/time
format argument can be used with Y=24 and Y=64 as well as with Y=4 and Y=44.

Any of the following can be used in the optional date/time format:
%a abbreviated weekday name
%A full weekday name
%b abbreviated month name
%B full month name
%d day of the month
%H hour using a 24-hour clock
%I hour using a 12-hour clock
%j day of the year (001-365)
%m month as a number

version 2.7.3 10



WXTOIMG(FAQ) WXTOIMG(FAQ)

%M minute
%p am/pm designation
%S second
%y year without a century
%Y year including the century
%Z time zone name or abbreviation
%% a ‘%’ character

Copyright
Copyright (c) 2001-2005 Abstract Technologies New Zealand Limited. All rights reserved.
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Upgrade
How do I upgrade?
Point your browser at:

http://www.wxtoimg.com/reg/

and follow the instructions. For a small fee you will be sent a personal upgrade key that you can use to
enable additional features.

If you do not have access to the Internet or prefer to register via mail or pay by cheque then you can post a
personal cheque in local currency for an equivalent of US$60.00 for the Standard Edition or US$100.00 for
the Professional Edition to:

Abstract Technologies New Zealand Limited
P.O. Box 113-126
Auckland
New Zealand

Be sure to include your name and postal address with the order and email address if you have one for fast
delivery of the upgrade key. Prices subject to change without notice. Please allow sev eral weeks for the
cheque to clear and mail to be delivered.

Why should I upgrade?
Upgrading helps make continuing development possible. Additionally, by upgrading additional features
become available. And 3-D glasses will be sent to those who upgrade (required to view the Anaglyph 3-D
enhancements).

There are two upgrade editions, the Standard Edition and the Professional Edition.

What additional features are enabled when I purchase the Standard Edition?
Anaglyph 3-D enhancements. These can provide a stunning way of viewing the cloud layers. They must
be viewed with special red/blue glasses (cardboard 3-D glasses will mailed to those who upgrade).

Adds enhancements with (estimated) precipitation overlays. Note that the precipitation overlays will not
function with narrow bandwidth receivers.

Greatly improved image quality for narrow bandwith receivers (e.g. scanners, communication receivers).

Web pages may be completely customised when you upgrade.

Enables many other projections (geographic transformations) including the Mercator Projection along with
enabling options (such as the centre or reference longitude, scale and boundaries) for controlling the trans-
formation of images from APT satellites.

Allows for the creation of animated movies of the images from multiple polar satellites (moving cloud, sta-
tionary land).

Composite images can be created from multiple polar satellite passes so as to cover a large area.

Enables image rotation cababilities along with colour shifting and grayscale conversion.

Allows a GPS (NMEA) to be used to automatically set the latitude and longitude.

Allows local time (instead of UTC time) to be displayed.

The latitude and longitude under the cursor are shown along with the distance (and direction) from the
ground station in APT images.

Information can be optionally displayed on the images in a selectable size font and colour. This can be
automated and can include the name of the satellite, time and location of the pass along with many other
details related to the satellite and image.

Tear-off menus are supported. This allows easier selection of enhancements and options through windows
which are always on screen. This option is not available on MacOS X.

Provides support for the control of the FT-847, PCR100/PCR1000, R2FX, SAN 200, WRX-137, Timestep
Proscan i-interface, AOR, Uniden Bearcat, ICOM, and Kenwood receivers and support for a user-supplied
radio control program.
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Allows the program to be configured to automatically enter record/decode mode at the start of a satellite
pass for completely automated recording.

In addition, future work will focus on features only for users who have purchased the standard edition.

Neither the standard edition nor the freeware edition can be used for commercial purposes.

What additional features are enabled when I purchase the Professional Edition?
The Professional Edition provides all the features of the Standard Edition, plus:

supplied with durable 3-D red/blue glasses with hard lenses (mailed to those who purchase a professional
edition upgrade key),

provides a choice of resample algorithms (for geographic transformation),

provides additional noise filter options,

provides additional contrast options, and

provides detailed control over which sensor is used for illumination with HVCT and HVC enhancements,
and

can be used for commercial purposes.

Thank You
in advance for your upgrade at:

http://www.wxtoimg.com/reg/

Copyright
Copyright (c) 2001-2005 Abstract Technologies New Zealand Limited. All rights reserved.
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